Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Pontiac > Trans Sport
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 06-03-2016, 06:39 PM   #1
Turek314
AF Newbie
 
Join Date: Jun 2016
Location: Saint Louis, Missouri
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
3 sensor codes

98 trans port has Egr, mass airflow sensor, and o2 sensor codes popping up. I've replaced all three and codes still active. First thought was the air filter, so I replaced that and codes still active. My next thought would be the catalytic converters might be clogged but unsure if that idea would set all these sensors off at the same time. Anyone knowledged on this? Help!?
Turek314 is offline   Reply With Quote
Old 06-04-2016, 08:30 PM   #2
Jeffrv
AF Regular
 
Jeffrv's Avatar
 
Join Date: Jun 2006
Location: North Bay
Posts: 178
Thanks: 0
Thanked 13 Times in 12 Posts
Re: 3 sensor codes

Did all 3 sensors throw the codes suddenly, and at the same time? If so, having all 3 go south simultaneously is rather rare. However, wiring issues common to these sensors could cause the problem, and given the age of the vehicle, a very likely problem. Not familiar with your vehicle, but if you could locate a wiring diagram, and see where the power and ground circuits to these 3 systems are common, and trace the wiring. On the older U bodies, the bulkhead connector for engine to body is a frequent source of problems such as this. Sometimes a quick way to find it was to wiggle, push, pull, squeeze the wiring bundle as the engine is running, and see if engine performance changes or CEL comes on. Be careful, however, of rotating parts as you do that.
Jeff
Jeffrv is offline   Reply With Quote
The Following 2 Users Say Thank You to Jeffrv For This Useful Post:
Tech II (06-05-2016)
Old 06-11-2016, 10:18 AM   #3
LMP
AF Enthusiast
 
LMP's Avatar
 
Join Date: Jun 2004
Location: Chicoutimi Quebec
Posts: 3,280
Thanks: 7
Thanked 59 Times in 59 Posts
Re: 3 sensor codes

Jeffry's post brings the attention to the fact that codes very often point to the consequence of some failure, sensors affected, rather than pointing to the cause....so pay due consideration to this...before paying for nothing.
__________________
'93 Ponty Transport 3.8; 2011 SUzuki SX4 AWD (wife's) ; 2015 Sorento 2.4 AWD 1928 Graham Paige Model 629
I don't believe in miracles.
LMP is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Pontiac > Trans Sport

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:27 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts