Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Buick > Park Avenue
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 12-17-2010, 05:45 AM   #1
Smith1000
AF Enthusiast
 
Join Date: Feb 2005
Location: Lawrence, Kansas
Posts: 574
Thanks: 0
Thanked 4 Times in 4 Posts
Oil Pressure 130 Pounds

I have an 02' PA and the oil pressure has been reading 129-130 pounds. I believe is must be the oil pressure sender. Has anyone experienced this problem? It was working okay last summer and I just noticed this recently. It otherwise runs great.
Smith1000 is offline   Reply With Quote
Old 12-17-2010, 08:15 AM   #2
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,624
Thanks: 16
Thanked 334 Times in 328 Posts
Re: Oil Pressure 130 Pounds

More than likely the sender is bad, to be sure hook up a mechanical gage at the sender port and see.
__________________
maxwedge is offline   Reply With Quote
Old 12-19-2010, 07:42 AM   #3
Smith1000
AF Enthusiast
Thread starter
 
Join Date: Feb 2005
Location: Lawrence, Kansas
Posts: 574
Thanks: 0
Thanked 4 Times in 4 Posts
Re: Oil Pressure 130 Pounds

That's got to be it. Thanks.
Smith1000 is offline   Reply With Quote
Old 12-21-2010, 08:12 AM   #4
yaz4real
AF Regular
 
Join Date: Sep 2006
Location: Gansevoort, New York
Posts: 156
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Oil Pressure 130 Pounds

This thread reminded me to look at my oil pressure reading. 129 NORMAL.
By a review of prior posts, it must be a trend. The '99 Ultra will get its new gauge switch shortly.
yaz4real is offline   Reply With Quote
Old 12-22-2010, 02:27 PM   #5
Jrs3800
AF Enthusiast
 
Join Date: Aug 2004
Location: Space Coast, Florida
Posts: 1,281
Thanks: 0
Thanked 28 Times in 28 Posts
Re: Oil Pressure 130 Pounds

This is common of most of the FWD GM's that have an oil pressure sender... When they go bad they most likely will read high..
Jrs3800 is offline   Reply With Quote
Old 12-29-2010, 10:55 PM   #6
BoomDaddy
AF Newbie
 
Join Date: Dec 2010
Location: Tonawanda, New York
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Oil Pressure 130 Pounds

I have had the notorious 129 or 130 oil pressure reading on 3 of my 3 Park Ave's. I have noticed this subject come up online a time or 2 and no one has ever mentioned something I have noticed.. On all 3 of my PA's when the oil pressure reading locks on 129 or 130, the rear window defroster also dies, and one day I remember smelling something like a wire burning and my wife had the heated seat on hi, the climate control set to max heat and max fan, and the rear defroster was on, and I suggested we're burning a wire in the dash. Soon after the smell came back on and the rear defroster quit at the moment the oil pressure locked on 129.

Since this has happened to 3 of 3 of my Park Ave's I feel strongly there is an issue with the wiring somewhere under or behind the dash. I haven't located this problem, nor have I ever had it fixed and I am very curious if anyone else finds this common to PA with respect to the rear defroster and oil pressure malfunctioning together. note that when I press the rear defroster button, it lights up and the mirrors heat up, but the rear window doesn't defrost and the voltage doesn't drop the typical .2-.3 v like a fully operational rear window grid does.

I hope I have maybe shed a light on this subject.

BoomDaddy

Last edited by BoomDaddy; 12-29-2010 at 10:59 PM. Reason: misspelled word.
BoomDaddy is offline   Reply With Quote
Old 01-01-2011, 01:12 PM   #7
yaz4real
AF Regular
 
Join Date: Sep 2006
Location: Gansevoort, New York
Posts: 156
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Oil Pressure 130 Pounds

'99 P/A Ultra 103k

Happy New Year !!!

It does seem like more than a coincidence.
I have reviewed all the posts searched under seats and defroster as well as heated mirrors including the HOTZ post about the resistor in the rear passenger pillar for a '94 P/A. I do have a driver's heated seat problem where there is clicking when turned on and no heat. The passenger side works fine. The driver's heated mirror is tinted like it has been heated excessively. The defroster or heated mirrors have not been tested to determine if they work or not.

It is difficult to determine where the interior fuse panels are for this vehicle to check for loose or frayed connections. Does anyone have insight to their locations and/or the diagram/schematics ?

I did replace the oil pressure sensor and its reading properly now.
yaz4real is offline   Reply With Quote
Old 03-27-2011, 01:22 AM   #8
bronzeback5
AF Newbie
 
Join Date: May 2009
Location: Wheatfield, Indiana
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Oil Pressure 130 Pounds

I have a 99 Ultra and my Oil Pressure is at 129 also. It has been stuck there for as long as i can remember. My driver heated seat is also out. Drivers mirror is burnt brown around the edges. Definitely not a coincidence.


Is this ACDELCO Part # 2131650 ??????

Last edited by bronzeback5; 03-27-2011 at 08:19 PM.
bronzeback5 is offline   Reply With Quote
Old 03-27-2011, 09:09 PM   #9
yaz4real
AF Regular
 
Join Date: Sep 2006
Location: Gansevoort, New York
Posts: 156
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Oil Pressure 130 Pounds

Thats the one !!!
yaz4real is offline   Reply With Quote
Old 03-31-2011, 08:46 PM   #10
HotZ28
AF Moderator Elite
 
HotZ28's Avatar
 
Join Date: Feb 2005
Location: Gilligan's Island, Florida
Posts: 5,759
Thanks: 81
Thanked 72 Times in 72 Posts
Re: Oil Pressure 130 Pounds

Quote:
Originally Posted by bronzeback5 View Post
. Drivers mirror is burnt brown around the edges. Definitely not a coincidence.
You're mirror may have moisture around the edges, causing the burning. BTW, the oil pressure sensor has nothing to do with the seat heater!
__________________
Knowledge can be communicated, but not wisdom!

HotZ28 is offline   Reply With Quote
Old 04-18-2011, 08:39 PM   #11
Smith1000
AF Enthusiast
Thread starter
 
Join Date: Feb 2005
Location: Lawrence, Kansas
Posts: 574
Thanks: 0
Thanked 4 Times in 4 Posts
Re: Oil Pressure 130 Pounds

I finally replaced the oil pressure sensor tonight. Had a heck of a time getting to it as it was below and behind the power steering pump and above the oil filter. There is not much room. Kind of reminded me of working on the old Subaru we used to have where everything was crammed in tight. The inner cv is also very close. I ended up cutting off part of the handle of a crescent wrench in order to gain room to turn it. I accessed it by taking off the front right tire. Seems okay now. It read 68 lbs at start up. Hope I don't ever have to replace another one. The sensor was about $40.
Smith1000 is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
'98 Regal.... no oil pressure after changed oil Mr_D Regal 6 04-06-2010 12:08 AM
Oil pressure gauge roknjock2 Chevrolet Classics 11 07-30-2009 08:33 AM
97 Pontiac Trans Sport Oil Pressure light mspontiac Trans Sport 2 07-07-2009 05:52 PM
No oil pressure on my big block 454BLAZER Problem Diagnosis 10 05-22-2009 12:37 AM
2001 Denali Low oil pressure w/ engine noise diddy0230 Yukon 1 05-11-2009 07:27 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Buick > Park Avenue

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:58 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts