Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Aurora
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 01-01-2005, 08:37 PM   #1
jo66tr
AF Newbie
 
Join Date: Dec 2003
Location: Defiance, Ohio
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
fuel rail not holding pressure

Hello, On my 1998 Aurora (114,000 miles) with new plugs, wires, fuel filter and FPR I noticed it seems to have more long hard start problems than it did before I changed everything. It seems like the relief valve to drain the pressure of does not hold a hole lot of pressure. Where else could it be losing the fuel pressure? There are no leaks anywhere that I can see. Thanks
jo66tr is offline   Reply With Quote
Old 01-02-2005, 05:35 AM   #2
Isnibs
AF Regular
 
Isnibs's Avatar
 
Join Date: Apr 2004
Location: Toronto
Posts: 201
Thanks: 0
Thanked 0 Times in 0 Posts
Did you fit the FPR 'O' rings properly?
__________________
1996 Aurora Black / grey
Isnibs is offline   Reply With Quote
Old 01-02-2005, 10:40 AM   #3
jo66tr
AF Newbie
Thread starter
 
Join Date: Dec 2003
Location: Defiance, Ohio
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Re: fuel rail not holding pressure

It was an Ac Deco and everything was already on it. I just put it in and snapped the o-ring on it. Would it leak if it was on wrong or just act up? Thanks
jo66tr is offline   Reply With Quote
Old 01-02-2005, 12:17 PM   #4
kmohr3
AF Regular
 
kmohr3's Avatar
 
Join Date: Oct 2004
Location: Machesney Park, Illinois
Posts: 461
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to kmohr3
Re: fuel rail not holding pressure

maybe an injector is leaking down when the car is shut off??
kmohr3 is offline   Reply With Quote
Old 01-02-2005, 12:27 PM   #5
jo66tr
AF Newbie
Thread starter
 
Join Date: Dec 2003
Location: Defiance, Ohio
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Re: fuel rail not holding pressure

I hooked up a pressure guage to it and it was dropping down to 0 as soon as the car was off. I took the FPR back out and found that the small O-ring on the bottom was just a little bigger than the one I took out and it cocked it in the groove. I put the old O-ring off of the other FPR and now I am holding 42 PSI for over 15 minutes, no leakdown and about 42-43 at idle. I will see now if it stops my hard start problems. Thanks
jo66tr is offline   Reply With Quote
Old 01-04-2005, 07:11 PM   #6
jo66tr
AF Newbie
Thread starter
 
Join Date: Dec 2003
Location: Defiance, Ohio
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Re: fuel rail not holding pressure

When I hook up the Fuel pressure guage now and fill the system with car off it rises about 4-5 psi after the fuel pump quits running then after about 15 minutes it loses 5-6 psi. Is there something wrong or is it normal to lose pressure after sitting? Thanks
jo66tr is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Aurora

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:26 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts