Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Blazer > Problem Diagnosis
Problem Diagnosis Got a problem you can't fix? Post here and one of our members will answer as soon as possible.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 12-03-2007, 12:01 AM   #1
jfoxxtail
AF Newbie
 
Join Date: Dec 2007
Location: victoria
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy engine light started blinking when going up hills, now it is always on

I recently swapped motors with another jimmy that had less miles. Not long after the engine was installed the engine light would blink when going up hills. When I would level out it would go off. When the speed was accelerated quickly to about 70mph/120kph the light would come on again. I changed the rotor and distributor as a start and nothing changed. I then changed the fuel filter and nothing changed. I added some octane boost fluid and it got worse, now the light is always on flashing.
When it is idling in park it runs very roughly like it is really misfiring. When it is on the road travelling it still has same horsepower but light is still on. Idling is biggest problem I have. Smell of exhaust is very rich, very gasoline-like, smells like it is a mixture problem.
I had it hooked up to a code reader but the reader said that the computer in the jimmy was shot. If I replace this computer will it correct idling problems? Help, do not have much $$$ to start taking it to shops to figure out. Thanks.
jfoxxtail is offline   Reply With Quote
Old 12-03-2007, 07:33 AM   #2
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,608
Thanks: 14
Thanked 331 Times in 325 Posts
Question Re: engine light started blinking when going up hills, now it is always on

Welcome to AF, what year, what engine, what codes? Then post back.
__________________
maxwedge is offline   Reply With Quote
Old 12-03-2007, 08:09 PM   #3
old_master
Advisor/Moderator
 
old_master's Avatar
 
Join Date: Nov 2005
Location: Belleville, Michigan
Posts: 5,183
Thanks: 6
Thanked 103 Times in 95 Posts
Re: engine light started blinking when going up hills, now it is always on

Diagnostic Trouble Codes, (DTC's) never tell you to replace a part, they tell you what circuit to check. Spark plugs and plug wires are a more likely cause for the symptoms you describe. As Maxwedge mentioned, we need more information to help you.

Last edited by old_master; 12-08-2007 at 09:20 AM.
old_master is offline   Reply With Quote
Old 12-03-2007, 08:15 PM   #4
4.6king
AF Newbie
 
Join Date: Nov 2007
Location: tjytyui
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Re: engine light started blinking when going up hills, now it is always on

flashing mil light means misfire
4.6king is offline   Reply With Quote
Old 12-04-2007, 01:11 AM   #5
jfoxxtail
AF Newbie
Thread starter
 
Join Date: Dec 2007
Location: victoria
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Re: engine light started blinking when going up hills, now it is always on

ac delco plugs were just put in about 6 mos ago. I think the code has a 2000 in it and I have a 4.3l vortec.
jfoxxtail is offline   Reply With Quote
Old 12-04-2007, 03:14 PM   #6
old_master
Advisor/Moderator
 
old_master's Avatar
 
Join Date: Nov 2005
Location: Belleville, Michigan
Posts: 5,183
Thanks: 6
Thanked 103 Times in 95 Posts
Re: engine light started blinking when going up hills, now it is always on

We need to know what DTC's are in memory, year of the vehicle, how many miles on the vehicle. Anything you can tell us about maintenance that has been done will help too.
old_master is offline   Reply With Quote
Old 12-05-2007, 03:23 PM   #7
jfoxxtail
AF Newbie
Thread starter
 
Join Date: Dec 2007
Location: victoria
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Re: engine light started blinking when going up hills, now it is always on

what are dtc's? The year of the vehicle is 95, it has been immaculately maintained. The mileage on old engine and tranny was about 350 kms, the one I put in was at about 120 kms.
jfoxxtail is offline   Reply With Quote
Old 12-05-2007, 08:14 PM   #8
old_master
Advisor/Moderator
 
old_master's Avatar
 
Join Date: Nov 2005
Location: Belleville, Michigan
Posts: 5,183
Thanks: 6
Thanked 103 Times in 95 Posts
Re: engine light started blinking when going up hills, now it is always on

1995 was a transition year from OBDI to OBDII and the vehicle could have either system. It requires the use of a special adapter to link the scan tool to the ECM in order to read the Diagnostic Trouble Codes (DTC's). If the correct adapter is not used, you may not get any codes at all, and to the untrained technician, it could be interpreted as a faulty ECM.
old_master is offline   Reply With Quote
Old 12-07-2007, 09:15 PM   #9
jfoxxtail
AF Newbie
Thread starter
 
Join Date: Dec 2007
Location: victoria
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Red face Re: engine light started blinking when going up hills, now it is always on

Okay, I have changed the spark plugs but I was given the wrong wires so those will have to wait for a bit. (I am on an island and do not get into the city too often.) One of the plugs that I had changed was destroyed! The metal part and the ceramic at the end was broken/burnt off! It was down to the nub of where the threads start, there was little left of anything sticking out past the threads. Another plug had the metal finger broken or burnt off. 3 of the others had rich deposits like gas and oil and one was fine. What would cause the plugs to do this? That may have been my problem.

I took it for a drive and the engine light stopped blinking, it blinked only when it was idling. I still have to change the wires to get a more complete diagnosis. Phew!!!

Last edited by jfoxxtail; 12-07-2007 at 10:01 PM.
jfoxxtail is offline   Reply With Quote
Old 12-07-2007, 09:27 PM   #10
old_master
Advisor/Moderator
 
old_master's Avatar
 
Join Date: Nov 2005
Location: Belleville, Michigan
Posts: 5,183
Thanks: 6
Thanked 103 Times in 95 Posts
Re: engine light started blinking when going up hills, now it is always on

What year is the engine that is in the vehicle now? The parts place may have given you the wrong plugs last time you changed them. What plug number was in it and what plug number is in it now?
old_master is offline   Reply With Quote
Old 12-07-2007, 10:07 PM   #11
jfoxxtail
AF Newbie
Thread starter
 
Join Date: Dec 2007
Location: victoria
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Re: engine light started blinking when going up hills, now it is always on

this motor is out of a '95 blazer. the old plugs were R44L TSM and the ones that I put in are RV15YC4. Maybe I was given the wrong plugs to begin with. When I changed the motor all was exactly the same so I assumed that it was the same thing that I had just changed. It didn't even occur to me to check the motor I have in now...my bad.
jfoxxtail is offline   Reply With Quote
Old 12-08-2007, 08:51 AM   #12
old_master
Advisor/Moderator
 
old_master's Avatar
 
Join Date: Nov 2005
Location: Belleville, Michigan
Posts: 5,183
Thanks: 6
Thanked 103 Times in 95 Posts
Re: engine light started blinking when going up hills, now it is always on

The AC R44L TSM plugs were wrong. The correct AC Delco spark plugs for your vehicle are CR43TS, use them! The Champion cross reference is RV12YC, which means the Champion RV15YC4 that they gave you are 3 heat ranges too hot. Leaving them in the engine is asking for trouble. It's always best to use the plugs that the vehicle manufacturer recomends.
old_master is offline   Reply With Quote
Old 12-18-2007, 05:24 AM   #13
jfoxxtail
AF Newbie
Thread starter
 
Join Date: Dec 2007
Location: victoria
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Re: engine light started blinking when going up hills, now it is always on

O.k., here's what I have done...I have bought the proper parts, wires and plugs, but I am having problems with the middle plug on the driver's side. The steering column is in the way and I cannot get a spark plug socket in with an access point to tighten it. I have tried a hose and I think i have gotten it in without cross threading it but am stuck with how to sufficiently tighten it. Remember I am on an island and I cannot get a contraption to snake in there. I have a hose and have rigged it up so that it got the plug threaded but now what? hehe, island life is great!!! Thanks man.
jfoxxtail is offline   Reply With Quote
Old 12-18-2007, 08:37 AM   #14
Sparky1349
AF Regular
 
Join Date: Apr 2007
Location: Highland Park, Illinois
Posts: 129
Thanks: 0
Thanked 0 Times in 0 Posts
Re: engine light started blinking when going up hills, now it is always on

Hey jfoxxtail,
Here is a path to follow for an easy way to get at that pesky middle spark plug:

Automotive Forums > Chevrolet > Blazer > How-to/Technical Info - How-to change the PITA #3 spark plug

or follow this link:

http://www.automotiveforums.com/vbul...d.php?t=503231

I have never tried this method but it sure does look easier than trying to wiggle your way around the steering shaft.

Good luck,
Sparky
Sparky1349 is offline   Reply With Quote
Old 12-18-2007, 05:39 PM   #15
old_master
Advisor/Moderator
 
old_master's Avatar
 
Join Date: Nov 2005
Location: Belleville, Michigan
Posts: 5,183
Thanks: 6
Thanked 103 Times in 95 Posts
Re: engine light started blinking when going up hills, now it is always on

http://www.automotiveforums.com/vbul...d.php?t=503231

I do it on every one, works like a charm! Takes about 5 minutes to remove and install the shaft. When the shaft is unbolted, and moved, the plug is right out in the open!
old_master is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Chevrolet > Blazer > Problem Diagnosis

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:09 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts