Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Saturn > SC/SL/SW
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 12-20-2017, 02:30 PM   #1
my94baby
AF Newbie
 
Join Date: Jul 2007
Location: Los Angeles, California
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
anyone tried a Blade filter? plus some issues

Hello!

It seems a little quiet here. Anyhow, I am thinking of getting a Blade exhaust filter for my 94 twin cam. (I can never remember if it's SL or what-all.)(Oh and also I need to measure my exhaust pipe to see if a Blade is even an option.)

Anyhow, first though, at my last smog check, the lovely young man told me I need a new catalytic converter, so I need to do that first.

But there are a couple other things that've been happening, so I thought I'd throw them out there and see if anyone has comments.

I have to add oil a lot more often these days, like once a week. Maybe a third or half a bottle. But it doesn't seem to be leaking. What does that probably mean?

It seems a bit more slow to accelerate than usual. Mind you, it was never what you'd call sporty. Is there a way to fix that, or is that like asking you to read me an encyclopedia?

My check engine light goes on and off sometimes, usually on the freeway and I may imagine this, but often if it has gone over something bumpy. (Also, it seems as though when I add coolant, this happens less.) This happens less than once a month though.

When I start the car in the mornings, there is a pretty strong gas smell. Naturally I feel bad for the neighbors. What might this mean and what could I do about it? (My friend said smoke/vapor came out too, once, when she saw me starting it.) I can't smell very well a lot of the time, but even I notice it.

Anyhow, does it sound like anything horrible is about to go wrong? Or is this just random, old car stuff?

And ... anyone tried a Blade?

Thanks for any and all comments!!! and Happy Holidays!!!!
my94baby is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Saturn > SC/SL/SW

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:27 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts