Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Volvo > 240
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 12-09-2007, 06:01 AM   #1
mweav
AF Newbie
 
Join Date: Dec 2007
Location: Pineville, North Carolina
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
1989 240 speedometer & odometer not working.

I purchased my first volvo two weeks ago. Yesterday, I drove my volvo to a friends house to perform some maintenance. I have a 1989 Volvo 240 DL. My odometer has not worked since I bought the car but my speedometer did. After my friend and I removed the cluster and replaced the gear that is common to have teeth broken off, we started the car and the odometer still did not work. My speedometer does not work now. The speedometer arm was fluctuating all over. It would go to zero, then fully peg to the top end and bounce everywhere in between. So I went to a salvage yard today and purchased another complete cluster. I put in the new gear from my other cluster and assembled.

The speedometer in this new cluster will not do anything and the odometer does not work. I now have a check engine light that is on when the car is started and running. This check engine light does not come on when I just turn the key and all the idiot lights come on, only after the car is started. Do I not have the new 25 tooth gear put in correctly? What would cause my speedometer to fail after replacing the 25 tooth gear? The whole cluster is electronic, even the speedometer. There is not a speedometer or odometer cable like in some cars.

What do I do? I'm very frustrated. Can anyone give me ideas about what to do? Thank you very much.
mweav is offline   Reply With Quote
Old 12-18-2007, 06:53 PM   #2
denisond3
AF Enthusiast
 
Join Date: Mar 2007
Location: VA in summer, TX in winter, Virginia
Posts: 1,323
Thanks: 2
Thanked 13 Times in 13 Posts
Re: 1989 240 speedometer & odometer not working.

The first thing would be to ensure you have replaced the wires to the back of the speedometer. Besides the larger connectors for the cluster, there is one small one for the speedometer/odometer, having about 3 wires to it. On our 88 240 there are also two other connectors that are single wires. I dont know what they do, but I made sure they got back onto their connectors.
denisond3 is offline   Reply With Quote
Old 01-02-2008, 07:05 AM   #3
mweav
AF Newbie
Thread starter
 
Join Date: Dec 2007
Location: Pineville, North Carolina
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1989 240 will not start.

I removed my throttle body from my car yesterday and cleaned it up. (It needed it.) I put it back on and started the car. It idled smoother than before cleaning this throttle body. I went back out 2 hours later to start the car and it would not start. I went back a half hour later and the same result. I pulled a spark plug and it was wet & smelt like gas was getting to the spark plugs. I then had a friend start the car as I held the spark plug wire coming from the primary coil next to pieces of metal on the car to see if there was an arch. No arch from wire. I just gave it a tune up two weeks ago. My wife is taking the spark plug wire going from the primary coil to the center of the distributor cap & the primary coil to AutoZone to see if they can test the primary coil. Any other ideas? Thanks.
mweav is offline   Reply With Quote
Old 01-02-2008, 10:09 AM   #4
denisond3
AF Enthusiast
 
Join Date: Mar 2007
Location: VA in summer, TX in winter, Virginia
Posts: 1,323
Thanks: 2
Thanked 13 Times in 13 Posts
Re: 1989 240 speedometer & odometer not working.

For the speedometer, it sounds like you need to get an entire speedo unit (or even a used cluster) from one of the ebay sellers. At least one of them is in the business of selling speedometers that he has reconditioned himself.
For the lack of spark: You probably need to get a manual and try to figure out which ignition system you have whether it has a diagnostic connector. Around the 88/89 time frame Volvo changed to a more sophisticated ignition control system called the EZ-116K. The spark timing is controlled by an external control unit, which gets signals from the Fuel system controller, a knock sensor, and other sensors. There is an electronic goody called a 'power stage' that fires the ignition coil. This system has a diagnostic capability, with a small box under the hood for the purpose. Ours is a 1988 240, which still has the earlier type system, not the EZ-116K.

There should be a VECI label on the drivers side strut tower, telling you which motor you have. I suppose yours would have the B230F engine.
I have the Haynes manual, which doesnt have as much detail about the electronics as I like. I think the Chilton's manual would not be much different. There is a thicker manual published by Bentley that is supposed to be better. You can usually find such manuals for sale on ebay. I know that Volvo also sold manuals, but they are harder to find now and cost the most. My personal opinion; if you are going to own an old Volvo, you will be much happier having a manual and being familiar with it.
denisond3 is offline   Reply With Quote
Old 01-08-2008, 08:27 AM   #5
mweav
AF Newbie
Thread starter
 
Join Date: Dec 2007
Location: Pineville, North Carolina
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1989 240 speedometer & odometer not working.

I replaced the Crank Sensor last night and the car started right away. Thank you to each person who posted suggestions to this thread. I also was able to buy another speedometer/clock cluster and replaced the plastic 15 tooth gear and now the odometer works. Thanks again.
mweav is offline   Reply With Quote
Old 05-07-2009, 02:14 AM   #6
Sweden1979
AF Newbie
 
Join Date: Apr 2009
Location: Osby, Sweden
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1989 240 speedometer & odometer not working.

about the speedometer. Check the connector on the rearaxel.
__________________
--------------------------------------------
Pontiac Trans Sport SE 3,1 -90
Sweden1979 is offline   Reply With Quote
Old 02-23-2018, 04:09 PM   #7
texaspep
AF Newbie
 
Join Date: Feb 2018
Location: georgetown, Texas
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1989 240 speedometer & odometer not working.

I'm having the same issue as MWEAV. I have replaced my odometer gears in my 1989 Volvo 240 DL. The tachometer was working previously but now the speedometer arm is fluctuating all over. "It would go to zero, then fully peg at the top end". All connections are correct.

I was told by the company from which I purchased the gears the following:

"There is a circuit breaker on the circuit board that can become tripped during the and removal and installation of the cluster. There is no way to manually reset this and you will just need to drive the vehicle for it to reset automatically. I have had clients drive for one to two weeks for it to reset but have not had one to date not reset using this method."

Can anyone tell me if this is correct? Does anyone else have any other trouble shooting solutions that I might try? I would appreciate any help.
texaspep is offline   Reply With Quote
Old 02-23-2018, 04:34 PM   #8
aleekat
AF Enthusiast
 
Join Date: Dec 2001
Location: clarksville, Tennessee
Posts: 1,317
Thanks: 1
Thanked 140 Times in 136 Posts
Re: 1989 240 speedometer & odometer not working.

Quote:
Originally Posted by texaspep View Post
I'm having the same issue as MWEAV. I have replaced my odometer gears in my 1989 Volvo 240 DL. The tachometer was working previously but now the speedometer arm is fluctuating all over. "It would go to zero, then fully peg at the top end". All connections are correct.

I was told by the company from which I purchased the gears the following:

"There is a circuit breaker on the circuit board that can become tripped during the and removal and installation of the cluster. There is no way to manually reset this and you will just need to drive the vehicle for it to reset automatically. I have had clients drive for one to two weeks for it to reset but have not had one to date not reset using this method."

Can anyone tell me if this is correct? Does anyone else have any other trouble shooting solutions that I might try? I would appreciate any help.
Lot of smart 240 owners here:
https://www.brickboard.com/RWD/index.htm?model=200
__________________
Post back, that's what makes Forums Work.
aleekat is offline   Reply With Quote
Old 02-23-2018, 05:22 PM   #9
texaspep
AF Newbie
 
Join Date: Feb 2018
Location: georgetown, Texas
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1989 240 speedometer & odometer not working.

thank you ALEEKAT!
texaspep is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Volvo > 240

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:06 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts