Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Geo > Metro
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-12-2022, 11:43 AM   #1
ebolton94
AF Newbie
 
Join Date: Oct 2022
Location: Sequim, Washington
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
No start, engine turns over

Hello,

First post! I am not a mechanic however I have learned what I can just from owning older vehicles for my whole life. I am not very knowledgeable of Geo Metros since I just got this car about 5 months ago. I have a 1995 Geo Metro, manual 3-cylinder, with 235k miles on it. New battery and new spark plugs.

Recently, my car has not been starting. The engine turns over consistently without hesitation. Before this happened, I don't recall any indication that there were any issues. The previous owner was a mechanic who loved this car and was very meticulous about oil changes, oil filter changes, air filter changes, and general maintenance.

So far, I have been using a 12V test light to help figure out what is going on. Based on the 12V test light, no power is getting to the coil/distributor/spark plugs. Additionally, I don't see any power coming into the coil, which I tested during when my wife had the key turned.

I checked the fuses, all fuses are getting power. I checked the relays, and even replaced the fuel pump relay. Now this is where it gets interesting, when I put the 12V test light into the prong-hole of the fuel-pump relay, the light does not turn on. I have also tested it when my wife turns the key to see if that makes a difference, but no. Note, the test light lit up when I tested all the other relays. So I've concluded that no power is getting to the fuel pump relay for some reason.

So now I'm kind of stumped and am not sure where to go from here. My father-in law says it could be the ignition switch. But my gut is telling me that if it was the ignition switch then the engine wouldn't be turning over like it is. Looking for any suggestions, I will also be browsing the forum for similar stories to see what I can learn.

Thanks,
Erik
ebolton94 is offline   Reply With Quote
Old 10-12-2022, 07:53 PM   #2
Blue Bowtie
Registered Offender
 
Blue Bowtie's Avatar
 
Join Date: Mar 2006
Location: Rural
Posts: 6,347
Thanks: 6
Thanked 316 Times in 313 Posts
Re: No start, engine turns over

A typical ignition switch operates several circuits, and not just the cranking of the starter. If the ignition switch is turned to the "run" position without cranking, do the instrument panel warning lamps and gauges operate?
__________________
Permanent seat assignment on the Group W bench...
Automotive Forums Survival Guide
Blue Bowtie is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD

Go Back   Automotive Forums .com Car Chat > Geo > Metro

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:46 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts