Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Alero
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 01-04-2016, 07:48 PM   #1
billman51
AF Newbie
 
Join Date: Jan 2016
Location: Phoenix, Arizona
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
intermittent turn signals

I have a 2001 Olds Alero with intermittent signals. I verified all fuses and proceeded to remove the multi-function switch, which had a burn on one contact. At times, I could tap the area of the column and they might work for a bit. I tested wiring per manual and replaced the multi-function switch. It all worked fine for a few days until the signals were not working again. The next day, I used the car and all was well again. I made sure the connector plugging into the switch had good and clean contacts. The hazard lights work fine so all bulbs are good and all fuses good. I'm kind of at a loss as to why the turn signals have an intermittent operation. I guess I missed something, but after working on vehicles for 35 years before retiring 6 years ago, I am confused on this one. Maybe one of our Olds owners have some ideas for me. Thanks in advance. Billman51
billman51 is offline   Reply With Quote
Old 01-04-2016, 10:38 PM   #2
Tech II
AF Fanatic
 
Join Date: Jul 2011
Location: Worcester, Massachusetts
Posts: 5,017
Thanks: 70
Thanked 617 Times in 609 Posts
Re: intermittent turn signals

Common problem for GM N bodies, Alero, Grand Am, etc.

It's the hazard switch.......next time the directionals don't work, turn them off, and turn your hazards on...turn them off....now try your directionals....if they now work, replace the Hazard Switch....there was a campaign for this......
Tech II is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Alero

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:23 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts