Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > Excursion
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-13-2004, 08:28 PM   #1
duneswest
AF Newbie
 
Join Date: Oct 2004
Location: mt pleasant, South Carolina
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
#6 fuse keeps blowing on 2000 Excursion

#6 fuse runs overhead computer, turn signals, rear a/c and back up lights. I replaced it with 15 amp fuse and after a few days it blows again. There is no rhyme or reason when it blows. You can run signal, rear a/c all day long and it won't blow. Then all of a sudden it goes out. Sometimes when the a/c, back up lights and signals are off.

The manual says a 15 amp is the proper fuse. Could it be they spec out a fuse too low in amps?

Any suggestions?
duneswest is offline   Reply With Quote
Old 10-15-2004, 12:37 PM   #2
rivguy
AF Regular
 
Join Date: Aug 2004
Location: Parchment, Michigan
Posts: 393
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to rivguy
Re: #6 fuse keeps blowing on 2000 Excursion

do you have signal mirrors?
__________________
-=-=-DANE-=-=-
rivguy is offline   Reply With Quote
Old 10-17-2004, 04:21 PM   #3
duneswest
AF Newbie
Thread starter
 
Join Date: Oct 2004
Location: mt pleasant, South Carolina
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: #6 fuse keeps blowing on 2000 Excursion

No signal mirrors.

It seem the problem started after we had the passenger side power window replaced due to a break in. This is the window on the middle seat. The window was changed out and the fuse was blown after we got the car back. I thought it was something simple like a fuse so I did not take it back to the shop. But it obviously is more than a bad fuse.
duneswest is offline   Reply With Quote
Old 07-24-2012, 02:18 PM   #4
paulshort67
AF Newbie
 
Join Date: Jul 2012
Location: lexington, Kentucky
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: #6 fuse keeps blowing on 2000 Excursion

Did you ever find out what the problem was with the fuse? in your excursion the number 6 fuse
paulshort67 is offline   Reply With Quote
Old 07-24-2012, 08:39 PM   #5
danielsatur
AF Enthusiast
 
Join Date: Mar 2008
Location: garner, North Carolina
Posts: 3,579
Thanks: 86
Thanked 100 Times in 100 Posts
Re: #6 fuse keeps blowing on 2000 Excursion

How doe's the window work?
Even though other circuits are not being used, the control module + sensors demand power.

If there's 3- circuits to a fuse, try isolating 1 or 2 of the circuits out of loop by a disconnect!

12volts/15 amp fuse = .8 ohms
danielsatur is offline   Reply With Quote
Old 08-06-2012, 02:43 PM   #6
kklgpadgett
AF Newbie
 
Join Date: Aug 2012
Location: Rochester, Minnesota
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Re: #6 fuse keeps blowing on 2000 Excursion

Sounds like a short in wiring. Pull panel on the door the window was replaced. also follow the wire by wire color to the fuse and disconet on on end check with tester.
kklgpadgett is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Ford > Excursion

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:48 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts