Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > Excursion
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 06-01-2009, 10:49 PM   #1
drkvamp
AF Newbie
 
Join Date: May 2009
Location: Minneapolis, Minnesota
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
V10 Excursion No Start

We have a 2001 Excursion... Just had to replace the E-brake pedal.. We loosened the computer to get it outta the way, but did not totally disconnect it, (with the negative battery cable off).. Now that it's all put back together, the truck won't start.. Please help immediately, as this is a limo and we need to get it back in service ASAP!!! All fuses check good, no access to a scanner, and the theft light stays off when the key's in the on position..
drkvamp is offline   Reply With Quote
Old 06-04-2009, 08:31 PM   #2
rhandwor
AF Enthusiast
 
Join Date: Sep 2006
Location: Athens, Georgia
Posts: 4,661
Thanks: 0
Thanked 64 Times in 64 Posts
Re: V10 Excursion No Start

Was a ground wire for the computer left disconnected?
rhandwor is offline   Reply With Quote
Old 06-07-2009, 01:46 AM   #3
fordtrucksonly
AF Regular
 
fordtrucksonly's Avatar
 
Join Date: Apr 2005
Location: Loganville, Georgia
Posts: 456
Thanks: 0
Thanked 2 Times in 2 Posts
Re: V10 Excursion No Start

It grounds through the connector... Does it spin over?
__________________
"When Lightning Strikes the Heartbeat Stops!"
'91 Mustang LX 347 StRoKeD & BlOwN
'04 Ford F-250 6L PS FX4
'95 Ford F-150
Ford Racing Pride
General Motors who?
2004-2008 Ford Master Certified Technician
fordtrucksonly is offline   Reply With Quote
Old 06-07-2009, 05:27 PM   #4
drkvamp
AF Newbie
Thread starter
 
Join Date: May 2009
Location: Minneapolis, Minnesota
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Re: V10 Excursion No Start

Spins/cranks all day long.. No fuel pressure.. Pump does not do it's run when key on.. BUT.... Pounding on it, doesn't do anything, NOR does spraying anything directly in..
drkvamp is offline   Reply With Quote
Old 06-07-2009, 07:50 PM   #5
Franco2112
AF Regular
 
Join Date: Sep 2008
Location: D/FW
Posts: 463
Thanks: 0
Thanked 0 Times in 0 Posts
Re: V10 Excursion No Start

Have you tried using a different key?
Franco2112 is offline   Reply With Quote
Old 06-08-2009, 12:28 AM   #6
fordtrucksonly
AF Regular
 
fordtrucksonly's Avatar
 
Join Date: Apr 2005
Location: Loganville, Georgia
Posts: 456
Thanks: 0
Thanked 2 Times in 2 Posts
Re: V10 Excursion No Start

he said the theft light dosent flash, so its not the PATS. I would say a bad relay.
__________________
"When Lightning Strikes the Heartbeat Stops!"
'91 Mustang LX 347 StRoKeD & BlOwN
'04 Ford F-250 6L PS FX4
'95 Ford F-150
Ford Racing Pride
General Motors who?
2004-2008 Ford Master Certified Technician
fordtrucksonly is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Ford > Excursion

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:23 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts