Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Toyota > Corona/Caldina/Carnia
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 03-25-2006, 09:30 PM   #1
grumps63
AF Newbie
 
Join Date: Mar 2006
Location: Gold Coast
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Question Lack of power

Hey guys, i've got a 85 Toyota corona avante, 2.4 efi (22RE engine) and have a slight problem. The car drives fine until u put ur foot down, and when u do this the car wont go over 2800-3000 RPM, when doing this u occasionally get a back fire but generally the car just wont move!!

I have replaced the dizzy cap, rotor button, leads, spark plugs, fuel pressure reg, had the injectors cleaned with an on car machine (which rules out a fuel pump problem), have replaced the coil, checked the TPS, ran BP ultimate fuel,checked the timing(correctly) umm, thats all i can think of for now? maybe the ignition module? .....just have no idea what else i can check, any help or ideas would be appreciated!!!
Cheers

Last edited by grumps63; 03-27-2006 at 01:55 AM.
grumps63 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Toyota > Corona/Caldina/Carnia

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:28 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts