Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > Thunderbird
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 07-16-2015, 08:53 PM   #1
Vipermcs76
AF Newbie
 
Join Date: Jul 2015
Location: North Haven, Connecticut
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Fuses

I have an 87 TBird Turbo Coupe that has been stored for fourteen years. Gas tank sprung a leak so had to change it. Replaced the fuel pump also. But the new battery was installed wrong and the starter solenoid was fried. Replaced it. Fuel pump works fine, and the car cranks fine but does not start. Where are the fuse links located in the engine compartment? I have yet to check the fuse box under the dash but will do so tomorrow. Hoping that a fuse link fried and replacing it will fix this. Lights and all ( except sunroof ) seem to be working. Any help would be appreciated. Just got back from overseas assignment and need this car until I can get a new one and restore this one.
Vipermcs76 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Ford > Thunderbird

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:57 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts