Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Saturn > LS/LW
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-29-2009, 09:01 AM   #1
CherokePrncs76
AF Newbie
 
Join Date: Oct 2009
Location: Charlottesville, Virginia
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
L300 Issues - Do you share my frustration? .....

I recently purchased a 2002 Saturn L300, It's probably been two and a half months now and the Service Engine Soon Light comes on, within 15 mins the car feels like it jumps as I am driving and or as it is accelerating. I get on the web and look up an questions, concerns, or recalls. I find out that there is an issue with the coolant temp sensor, which can cause the service engine light to come on. The next day I call the dealership and schedule a time to take my car in to be fix (warranty). Well, here it is a Thursday the car was in the shop on Monday and I was called to pick it up yesterday - This morning my Service Wrench light comes on and my car is jumping again - Would anyone have any answers to my curent diliema???????? .......
CherokePrncs76 is offline   Reply With Quote
Old 02-13-2010, 07:52 AM   #2
kknobl
AF Newbie
 
Join Date: Feb 2006
Location: Levittown, Pennsylvania
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Re: L300 Issues - Do you share my frustration? .....

Quote:
Originally Posted by CherokePrncs76 View Post
I recently purchased a 2002 Saturn L300, It's probably been two and a half months now and the Service Engine Soon Light comes on, within 15 mins the car feels like it jumps as I am driving and or as it is accelerating. I get on the web and look up an questions, concerns, or recalls. I find out that there is an issue with the coolant temp sensor, which can cause the service engine light to come on. The next day I call the dealership and schedule a time to take my car in to be fix (warranty). Well, here it is a Thursday the car was in the shop on Monday and I was called to pick it up yesterday - This morning my Service Wrench light comes on and my car is jumping again - Would anyone have any answers to my curent diliema???????? .......

Could be your MAF sensor. When these go bad, they have potential to play havoc on your car, as this is what determines fuel trims, shift points, etc, based on your driving style.
kknobl is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Saturn > LS/LW

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:41 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts