Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Geo > Storm
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 04-22-2009, 09:58 PM   #1
1=2
AF Newbie
 
Join Date: Apr 2009
Location: SLC, Utah
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Timing belt issues

Okay, I hate this car already. I've driven it for 3 days, and it's already eaten 2 serpentine belts, 1 battery and now a timing belt. But anyway, I have know something.

I have a 93' Storm GSI, 1.8 liter Isuzu twin cam motor. I bought the car 130 miles ago and it has 87K on it, and the timing belt skipped on me. I need to know if it's an interference engine. I've looking online and have found 3 claims that it's not an interference engine, and 1 that says it is. I need evidence and the facts, because if the valves are bent, then screw it, the car is going to the junkyard. But if not, then I'll put a new belt on it and sell it. Thanks guys.
1=2 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Geo > Storm

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:21 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts