Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mitsubishi > Galant
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 05-04-2010, 02:19 PM   #1
1102Galant
AF Newbie
 
Join Date: May 2010
Location: Chicago, Illinois
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
2002 Galant LS Oil Pressure/Sensor? Help?

Hi All -

I own a 2002 Galant LS with 75400 miles on it. Recently the oil light has been flickering on and off when she has been idling or under 1000 rpms. I have checked the oil and it's where it should be, and it also does not appear to be leaking any oil. Other than that the car is not running abnormally.

I have read on other forums that it could be an issue with the oil sensor?

Anyone have any recommendations on what I should do before taking it in?

Thanks!
1102Galant is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Mitsubishi > Galant

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:00 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts