Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mercury > Grand Marquis
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 09-13-2018, 08:22 AM   #1
JGM2005
AF Newbie
 
Join Date: Sep 2018
Location: Columbus, Ohio
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
2005 Grand Marquis Blower quit

Blower did not work; friend said was probably resistor so replaced it and blower motor (and a hose that was in way)
Worked when test drove it and then sat 2 days get it Nothing now
Did not replace or check relay small fuses related to AC looked good
What next?
I am not even a back yard mechanic but am trying..
Thanks in advance
JGM2005 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Mercury > Grand Marquis

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:28 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts