Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Dodge > Ram Van
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 09-28-2016, 11:28 AM   #1
Max Draft
AF Newbie
 
Join Date: Sep 2016
Location: Garrison, New York
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
1999 B3500, 5.9L, stalls unless PCV pulled out.

Hi, I'm new to the forum and look forward to your suggestions. I have a 1999 B3500 Van with a 5.9L, 125,000miles. When I run it from a cold start for maybe 20 miles it runs fine. After it sits for an hour or two and I start it up it stalls shortly after. One time all the dash gauges went crazy but eventually corrected itself. Reading the forum I have tried cleaning the throttle body and IAC and I replaced the PCV with a new non-MOPAR part. When this happens I found if I pull the PCV out (Still attached to the hose but free of the valve cover) it starts right up and runs fine. What's happening?
Max Draft is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Dodge > Ram Van

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:21 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts