Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > ZX2
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-07-2012, 10:49 AM   #1
amiller17
AF Newbie
 
Join Date: Oct 2012
Location: Martinsville, Ohio
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Heater blows cold air

I have a 2003 zx2 and the heater the other night ran nothing but cold air. Checked the coolant and it was low, but after adding coolant it still feels like the ac is on and not the heater. Winter is coming and I have to get this fixed ASAP. I believe it could be thermostat or heater core. Is there anyway of testing this to see which it is? I guess I should say I am female and I have 0 mechanic skills. Please help!:bang head:
amiller17 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Ford > ZX2

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:20 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts