Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mazda > MX-3
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 05-25-2015, 06:13 AM   #1
jdsdad71
AF Newbie
 
Join Date: May 2015
Location: Elk Grove
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
'93 mx3 1.8 no spark for 5 months Please help

My 1993 mx3 ran when I first got it. We bought it from a neighbor friend the only problems were that it needed a water pump and a oil cap. There was a sock there insisted but the car had never over heated or ran out of oil. But it was every where under the hood. Well I ran some errands and when I got back as friend of mine has sprayed coil cleaner all over the engine without covering anything. Well then is when the problems started it started to run bad that's when I found a 1\4 inch crack in the ingnition cobtroll moduler\ distributor plate.well I could not find a new one so I jb weld that and used it. I changed the water pump timing belt and the other belts. There was a dissagrement on timing since nobody marked anything before taking the belts off. Well needless to say it didn't start. Then we had no spark. Finally a few days after tweaking I got sparknp
Back so I wanted to get it home so I took off for the house it was night cold and wet so I used every thing electrical in there so I could see. Got on the free way and everything started to go dim like the battery was dieing . well it died and wouldn't start had itvtowed home with no spark again and that's where it has sat for 5months while I tried to work on it but I'm disabled ant its hsrd. I've had friends help but we can't pin point the problem. Please someone help me give me some advise I want my car
jdsdad71 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Mazda > MX-3

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:24 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts