Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Camaro | Firebird > F-Body Problem Diagnosis
F-Body Problem Diagnosis Got a problem you can't fix? Post here and one of our members will answer as soon as possible.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 07-31-2018, 09:06 PM   #1
rushedusername
AF Newbie
 
Join Date: Jun 2018
Location: Advance, North Carolina
Posts: 2
Thanks: 2
Thanked 0 Times in 0 Posts
Hazards not working

I own a 2000 Firebird V6, and whenever I try to turn on the hazards, neither the front or taillights would flash. Checked the fuse, but it was good. When turning on the hazards, it would click rapidly at the first couple of seconds, then slow down onto a consistent rate. The regular turns signals do work. I really need to know what's happening to pass inspection. Please Help
rushedusername is offline   Reply With Quote
Old 08-01-2018, 10:09 PM   #2
Blue Bowtie
Registered Offender
 
Blue Bowtie's Avatar
 
Join Date: Mar 2006
Location: Rural
Posts: 6,055
Thanks: 4
Thanked 259 Times in 255 Posts
Re: Hazards not working

There is a reasonable chance that the contacts in the multifunction switch in the steering column are failing. It may be possible to alleviate that by exercising the switch numerous times. They may wipe clean enough to provide good contact, or may not. It's easier than dismantling the column to replace the switch.
__________________
Permanent seat assignment on the Group W bench...
Automotive Forums Survival Guide
Blue Bowtie is offline   Reply With Quote
Old 08-02-2018, 06:28 AM   #3
Tech II
AF Fanatic
 
Join Date: Jul 2011
Location: Worcester, Massachusetts
Posts: 5,017
Thanks: 70
Thanked 617 Times in 609 Posts
Re: Hazards not working

As Blue stated, it could be the hazard switch contacts.....

It could also be the hazard flasher.....quick test would be to remove the hazard flasher, not the turn signal flasher, and using a jumper in the harness, now press your hazard switch......if the lights come on solid, it's the flasher.....if they don't, verify power on the orange line with a grounded test light.....if you have power, than more than likely it is the multifunction switch since your directionals work.....
Tech II is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
firebird, hazards, pontiac
Go Back   Automotive Forums .com Car Chat > Chevrolet > Camaro | Firebird > F-Body Problem Diagnosis

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:31 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts