Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Buick > LaCrosse/Allure
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 11-05-2019, 08:39 AM   #1
codydog
AF Newbie
 
Join Date: Sep 2006
Location: Pottstown, Pennsylvania
Posts: 7
Thanks: 0
Thanked 1 Time in 1 Post
2010 Lacrosse

Hello my wife started the lacrosse and it was reving very high. Stepping on gas petal did not lower or raise it. The shifter would move but it would not go into gear. Also the light for the gear would not light up. Check engine light was on and big red break light was on. Car only has about 50,000 and is driven every day. Turn off hit the pedal and turned on again it worked. turned off and turned on wouldn't go into gear. We have left it in the driveway for today.

Thanks for any help
codydog is offline   Reply With Quote
The Following User Says Thank You to codydog For This Useful Post:
maxwedge (11-05-2019)
Old 11-05-2019, 02:58 PM   #2
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,592
Thanks: 14
Thanked 327 Times in 321 Posts
Re: 2010 Lacrosse

ok, you put it gear, and the trans won't engage? Is the check engine lite all the time now?
__________________
maxwedge is offline   Reply With Quote
Old 11-05-2019, 03:48 PM   #3
codydog
AF Newbie
Thread starter
 
Join Date: Sep 2006
Location: Pottstown, Pennsylvania
Posts: 7
Thanks: 0
Thanked 1 Time in 1 Post
Re: 2010 Lacrosse

Hello,

Yes that is correct. I only had 5 minutes to play with it I am going home now to further investigate. It is the 3 liter engine also. I was thinking possibly the throttle sensor.
codydog is offline   Reply With Quote
Old 11-05-2019, 09:18 PM   #4
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,592
Thanks: 14
Thanked 327 Times in 321 Posts
Re: 2010 Lacrosse

Try and get a code reader on it post back codes.
__________________
maxwedge is offline   Reply With Quote
Old 11-06-2019, 08:02 AM   #5
codydog
AF Newbie
Thread starter
 
Join Date: Sep 2006
Location: Pottstown, Pennsylvania
Posts: 7
Thanks: 0
Thanked 1 Time in 1 Post
Re: 2010 Lacrosse

I am getting a code reader today. Also there is no response from the gas pedal. You push on it and get nothing.
codydog is offline   Reply With Quote
Old 11-15-2019, 03:19 PM   #6
codydog
AF Newbie
Thread starter
 
Join Date: Sep 2006
Location: Pottstown, Pennsylvania
Posts: 7
Thanks: 0
Thanked 1 Time in 1 Post
Re: 2010 Lacrosse

Sorry for the delay. Family issues. Got code P0700 and P182E. Could get it to do anything made sure there was fluid in the trans(it was low) then tried to clear codes. They would not clear. Car still wouldn't move. Gave up since wife wanted fixed right away and got it towed. It worked eversice it arrived at the garage they drove it everyday multiple places for 5 days. They said the codes showed it was the neutral safety switch but that seems a little odd. Got it yesterday and it is working.

Thoughts?

Thank you and again sorry for the no contact period.
codydog is offline   Reply With Quote
Old 11-15-2019, 08:00 PM   #7
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,592
Thanks: 14
Thanked 327 Times in 321 Posts
Re: 2010 Lacrosse

If the pcm sees the wrong gear selection from the neutral switch many functions can be skewed.
__________________
maxwedge is offline   Reply With Quote
Old 11-17-2019, 01:47 PM   #8
codydog
AF Newbie
Thread starter
 
Join Date: Sep 2006
Location: Pottstown, Pennsylvania
Posts: 7
Thanks: 0
Thanked 1 Time in 1 Post
Re: 2010 Lacrosse

Ok. Would it just fix itself though
codydog is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Buick > LaCrosse/Allure

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:19 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts