Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Hyundai > Sonata
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-15-2019, 08:15 PM   #1
hondajoe88
AF Newbie
 
Join Date: Apr 2004
Location: Quincy, Massachusetts
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
2017 Hyundai Sonata SE low-beam on driver's side not working

The other day my left-front headlight stopped working and I got an indication on the console messaging to that effect. I checked the resistance of the bulb and it
was NOT burnt out. So I started thinking fuse, shorts, etc..

So I started to scrounge through the two fuse-boxes - under-hood and driver's side under-dash. I then found that there is NO obvious
low-beam fuse. By the way, the high beams work fine.

Not having a schematic yet for this car since I just bought it a couple months ago and haven't ordered the service manual, I decided
to try the fuse box anyway. There are modules and such like module 3 etc.. Eventually, I found that by wiggling the left-front headlight
connect and pushing in certain directions that the left-front headlight will go on.

My question is:
1) Can I remove the entire left-front headlight system's wiring somehow so I can better look for a short? By the way, when I turn
the headlights on, the amount of dim I see in the interior console seems out of proportion (as if there WAS a short or parastic draw).

2) I know how to use an ohmmeter to check for parasitic draws - I will do this.

But can I get a schematic of this stuff from someone - any help appreciated and/or advice?

I guess I need to simply FIRST: Make sure that the harness is good to go - I can replace all the wires if need be - I'm good at wiring stuff.
My biggest problem is - is it the harness connector wires not being pushed in - you know how it goes, I just have to figure all that stuff out? First check the wires, then the connectors, etc..

The hardest part is accessing it since it's all tucked in down the tube that the headlight low-beam goes in - the one I first removed from the car to
measure it's resistance.

So I don't have a problem trouble-shooting this in theory, I just would seem to struggle pulling all the wires out - any suggestions appreciated.

I'm guessing it's not the module controller, but simply a short in the wiring and/or possibly an open-circuit. When I push on all the wires, the headlight always
eventually goes on for a time. Then the next time I start the car, it normally does NOT work again. This has me a little perplexed, making me think a controller might be involved. I DID
removed the module 3 fuse and re-insinert it at one point but not with the key and lights on.

So I'm posting this to make sure I'm not missing something that someone already knows about my model of Hyundai. Tomorrow, I will go out
and try to remove all the wiring to the left front headlight and carefully inspect it and possibly I might just patch in my own headlight circuit and fuse
until I can sort throught it all.

I'm not terribly worried since I can put my own circuit in - it's more like I'm disappointed that Hyundai doesn't give us a fail-safe where we can
patch in a simple circuit - I could care less about the sensors if they aren't reliable. I would say a big no thanks to that circuitry since
I hear horror stories all the time.

Am I right to feel this way? Or am I just too cynical? Honestly, I don't know the answer to those questions.

Any opinions respected by me.
hondajoe88 is offline   Reply With Quote
Old 10-16-2019, 12:42 PM   #2
hondajoe88
AF Newbie
Thread starter
 
Join Date: Apr 2004
Location: Quincy, Massachusetts
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2017 Hyundai Sonata SE low-beam on driver's side not working

Can someone please post where I can get the 2017 Hyundai Sonata Service manual from a site that you know and can attest to that they give you a pdf file link.

I just tried ordering one, and they ripped me off - it was a scam. There's one in the UAE - is it legitimate? It costs 79.99, not a bad price if it's really going to give me that manual. The site with the rip-off was for a 2016 manual for only 29.99. But I never got the link so I disputed the transaction in Paypal and hopefully will receive a refund.

Thanks.

Quote:
Originally Posted by hondajoe88 View Post
The other day my left-front headlight stopped working and I got an indication on the console messaging to that effect. I checked the resistance of the bulb and it
was NOT burnt out. So I started thinking fuse, shorts, etc..

So I started to scrounge through the two fuse-boxes - under-hood and driver's side under-dash. I then found that there is NO obvious
low-beam fuse. By the way, the high beams work fine.

Not having a schematic yet for this car since I just bought it a couple months ago and haven't ordered the service manual, I decided
to try the fuse box anyway. There are modules and such like module 3 etc.. Eventually, I found that by wiggling the left-front headlight
connect and pushing in certain directions that the left-front headlight will go on.

My question is:
1) Can I remove the entire left-front headlight system's wiring somehow so I can better look for a short? By the way, when I turn
the headlights on, the amount of dim I see in the interior console seems out of proportion (as if there WAS a short or parastic draw).

2) I know how to use an ohmmeter to check for parasitic draws - I will do this.

But can I get a schematic of this stuff from someone - any help appreciated and/or advice?

I guess I need to simply FIRST: Make sure that the harness is good to go - I can replace all the wires if need be - I'm good at wiring stuff.
My biggest problem is - is it the harness connector wires not being pushed in - you know how it goes, I just have to figure all that stuff out? First check the wires, then the connectors, etc..

The hardest part is accessing it since it's all tucked in down the tube that the headlight low-beam goes in - the one I first removed from the car to
measure it's resistance.

So I don't have a problem trouble-shooting this in theory, I just would seem to struggle pulling all the wires out - any suggestions appreciated.

I'm guessing it's not the module controller, but simply a short in the wiring and/or possibly an open-circuit. When I push on all the wires, the headlight always
eventually goes on for a time. Then the next time I start the car, it normally does NOT work again. This has me a little perplexed, making me think a controller might be involved. I DID
removed the module 3 fuse and re-insinert it at one point but not with the key and lights on.

So I'm posting this to make sure I'm not missing something that someone already knows about my model of Hyundai. Tomorrow, I will go out
and try to remove all the wiring to the left front headlight and carefully inspect it and possibly I might just patch in my own headlight circuit and fuse
until I can sort throught it all.

I'm not terribly worried since I can put my own circuit in - it's more like I'm disappointed that Hyundai doesn't give us a fail-safe where we can
patch in a simple circuit - I could care less about the sensors if they aren't reliable. I would say a big no thanks to that circuitry since
I hear horror stories all the time.

Am I right to feel this way? Or am I just too cynical? Honestly, I don't know the answer to those questions.

Any opinions respected by me.
hondajoe88 is offline   Reply With Quote
Old 10-16-2019, 03:27 PM   #3
hondajoe88
AF Newbie
Thread starter
 
Join Date: Apr 2004
Location: Quincy, Massachusetts
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2017 Hyundai Sonata SE low-beam on driver's side not working

Noone seems to have a schematic but it seems to me that somewhere there is a relay that only closes if I wiggle the wires leading up to the left low-beam. Then once I do that, it won't work the next time since there is some other subtle problem in the system. Something is not allowing the relay to ground properly unless I short something out?

Hard to tell.

Quote:
Originally Posted by hondajoe88 View Post
Can someone please post where I can get the 2017 Hyundai Sonata Service manual from a site that you know and can attest to that they give you a pdf file link.

I just tried ordering one, and they ripped me off - it was a scam. There's one in the UAE - is it legitimate? It costs 79.99, not a bad price if it's really going to give me that manual. The site with the rip-off was for a 2016 manual for only 29.99. But I never got the link so I disputed the transaction in Paypal and hopefully will receive a refund.

Thanks.
hondajoe88 is offline   Reply With Quote
Old 10-17-2019, 01:16 PM   #4
hondajoe88
AF Newbie
Thread starter
 
Join Date: Apr 2004
Location: Quincy, Massachusetts
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2017 Hyundai Sonata SE low-beam on driver's side not working

I'll have to take the grill and lens off tomorrow I guess. Inserting a tube won't work since the wires pass through a very tiny orifice and it has a turn in it - perhaps that's where the problem lies since it's pinched.

Quote:
Originally Posted by hondajoe88 View Post
Noone seems to have a schematic but it seems to me that somewhere there is a relay that only closes if I wiggle the wires leading up to the left low-beam. Then once I do that, it won't work the next time since there is some other subtle problem in the system. Something is not allowing the relay to ground properly unless I short something out?

Hard to tell.
hondajoe88 is offline   Reply With Quote
Old 10-17-2019, 02:26 PM   #5
hondajoe88
AF Newbie
Thread starter
 
Join Date: Apr 2004
Location: Quincy, Massachusetts
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2017 Hyundai Sonata SE low-beam on driver's side not working

Quote:
Originally Posted by hondajoe88 View Post
I'll have to take the grill and lens off tomorrow I guess. Inserting a tube won't work since the wires pass through a very tiny orifice and it has a turn in it - perhaps that's where the problem lies since it's pinched.
Today I had to push right at the connector to the bulb assembly to get the light to go on - pushing on the wires didn't help so I wonder if it's the connector but yet there is no voltage at all if I unhook the bulb. But perhaps I should wiggle the connector with the bulb unhooked - could the wire be cracked right at the little female end of the connector?
hondajoe88 is offline   Reply With Quote
Old 10-17-2019, 02:48 PM   #6
Copytech99
AF Regular
 
Join Date: May 2005
Location: somewhere, Ohio
Posts: 429
Thanks: 5
Thanked 18 Times in 18 Posts
Re: 2017 Hyundai Sonata SE low-beam on driver's side not working

Corroded connections, at bulb & connector terminals ?
Copytech99 is offline   Reply With Quote
Old 10-18-2019, 01:41 AM   #7
hondajoe88
AF Newbie
Thread starter
 
Join Date: Apr 2004
Location: Quincy, Massachusetts
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2017 Hyundai Sonata SE low-beam on driver's side not working

Quote:
Originally Posted by Copytech99 View Post
Corroded connections, at bulb & connector terminals ?
Hi, neither bulb(s), nor connector are corroded.

I'm using 9005 bulb now which seems similar to the one I took out, also a Sylvania.

I don't yet have a procedure to get the lense out. I might replace the connector but frankly, I always have to push a lot on the wires and connector to get it to go on but none of that stuff looks wrong which still makes me think it's a wire. But it COULD just be the connector and Autozone doesn't sell a connector for the 9005 bulb. I might have to try other bulbs. Tomorrow I'll check the right side. The stuff is all cheaply made
hondajoe88 is offline   Reply With Quote
Old 10-18-2019, 05:25 PM   #8
hondajoe88
AF Newbie
Thread starter
 
Join Date: Apr 2004
Location: Quincy, Massachusetts
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2017 Hyundai Sonata SE low-beam on driver's side not working

Quote:
Originally Posted by hondajoe88 View Post
Hi, neither bulb(s), nor connector are corroded.

I'm using 9005 bulb now which seems similar to the one I took out, also a Sylvania.

I don't yet have a procedure to get the lense out. I might replace the connector but frankly, I always have to push a lot on the wires and connector to get it to go on but none of that stuff looks wrong which still makes me think it's a wire. But it COULD just be the connector and Autozone doesn't sell a connector for the 9005 bulb. I might have to try other bulbs. Tomorrow I'll check the right side. The stuff is all cheaply made
To make a long story short: the problem was in the main 8-wire cable that feeds the let-front headlight systems their power.

A rodent which I actually saw crawl out from under the car one day at work, had gnawed just enough on the cable of 8 to pierce the insulation and eventually the wire was not making good enough contact except when it was wiggled and by chance, conntected.

So headlight problem is fixed - one new wire put in as the connector comes apart and allows for splicing in a new wire.


Headlights seem fine now.

Not the first time I've had rodents gnaw through the wires in my car - even lost my fuel-pump ground G302 on a Honda once.
hondajoe88 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Hyundai > Sonata

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:41 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts