Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Lincoln > MKT
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 01-07-2021, 09:18 AM   #1
harleyguy
AF Regular
 
Join Date: Apr 2016
Location: McPherson
Posts: 111
Thanks: 0
Thanked 7 Times in 7 Posts
Ford flex lean code, won't run

Working on my grandpa's ford flex. It will start but won't hardly idle and no throttle response. Pulled codes i don't remember the numbers but they were for o2 lean both banks.
To me it acts like a large vacuum leak. I couldn't find any or hear any.
I unplugged the MAF and it starts and runs as good as can be expected with the MAF unplugged. Running like this i still couldn't find a vacuum leak.
I'm leaning towards thinking it's a bad MAF. I looked it over and it looks clean. I just wanted to confirm with someone smarter than me before I spend $100.
harleyguy is offline   Reply With Quote
Old 01-07-2021, 08:54 PM   #2
shorod
SHO Off
 
shorod's Avatar
 
Join Date: Jun 2004
Location: Cedar Rapids, Iowa
Posts: 10,791
Thanks: 80
Thanked 329 Times in 323 Posts
Re: Ford flex lean code, won't run

If it's runs better with the MAF unplugged the issue is probably not the MAF. If unplugging the MAF had no effect, then I might be a bit more encouraged to think the MAF is the issue, but I still wouldn't jump to suspecting it.


Which engine does his Flex have? Have you checked all the intake air tubing to make sure it's securely and properly connected? Any chance you have access to a fog machine the better check for vacuum leaks? If not, and you have a fire extinguisher nearby, you can use throttle body cleaner to help locate vacuum leaks.


-Rod
shorod is offline   Reply With Quote
Old 01-07-2021, 10:40 PM   #3
Stealthee
Your worst nightmare
 
Stealthee's Avatar
 
Join Date: Oct 2004
Location: Smithfield, Pennsylvania
Posts: 5,917
Thanks: 13
Thanked 225 Times in 220 Posts
Re: Ford flex lean code, won't run

I wouldn't point at the MAF with a lean code. If the MAF were the issue it would run better with it unplugged than it does with it plugged in.

Finding a vacuum leak by just looking or listening isn't always going to get results. A leak at the throttle body or intake manifold may not be apparent. Start it and start spraying brake cleaner in various areas. If idle increases you've found the area of your leak.
__________________
Stealthee is offline   Reply With Quote
Old 01-10-2021, 09:20 AM   #4
harleyguy
AF Regular
Thread starter
 
Join Date: Apr 2016
Location: McPherson
Posts: 111
Thanks: 0
Thanked 7 Times in 7 Posts
Re: Ford flex lean code, won't run

Sorry I haven't updated. I will look harder for a vacuum leak. Haven't had time to look at it.
harleyguy is offline   Reply With Quote
Old 01-14-2021, 07:13 PM   #5
harleyguy
AF Regular
Thread starter
 
Join Date: Apr 2016
Location: McPherson
Posts: 111
Thanks: 0
Thanked 7 Times in 7 Posts
Re: Ford flex lean code, won't run

I took brake clean (real stuff not CA non-flammable crap) couldn't get it to pick up anywhere. I pulled the intake hose to get a better inspection on it. While it was off I sprayed down the MAF. Put it all back together and cleared codes. All works well.
harleyguy is offline   Reply With Quote
Old 01-16-2021, 03:59 PM   #6
shorod
SHO Off
 
shorod's Avatar
 
Join Date: Jun 2004
Location: Cedar Rapids, Iowa
Posts: 10,791
Thanks: 80
Thanked 329 Times in 323 Posts
Re: Ford flex lean code, won't run

Thank you for following up. What are the chances you have a performance air filter that uses oil to help trap dirt?

-Rod
shorod is offline   Reply With Quote
Old 01-17-2021, 07:29 AM   #7
harleyguy
AF Regular
Thread starter
 
Join Date: Apr 2016
Location: McPherson
Posts: 111
Thanks: 0
Thanked 7 Times in 7 Posts
Re: Ford flex lean code, won't run

It's all stock. 2014 with 30000 miles. Grandpa drives it maybe once a week.
harleyguy is offline   Reply With Quote
Old 01-17-2021, 09:44 AM   #8
shorod
SHO Off
 
shorod's Avatar
 
Join Date: Jun 2004
Location: Cedar Rapids, Iowa
Posts: 10,791
Thanks: 80
Thanked 329 Times in 323 Posts
Re: Ford flex lean code, won't run

Okay, thanks. It's common for MAF sensors to start to behave weirdly if they get coated with the oil from the reusable air filters. It seems this is mostly the case after the filters are cleaned and then over-oiled. It doesn't sound like this should be an issue with your Grandpa's Flex.

-Rod
shorod is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD

Go Back   Automotive Forums .com Car Chat > Lincoln > MKT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:57 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts