Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Hyundai > Elantra | Avante
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 08-19-2017, 06:39 PM   #1
heliosense
AF Newbie
 
Join Date: Aug 2017
Location: Hamilton
Posts: 5
Thanks: 5
Thanked 0 Times in 0 Posts
2017 Elantra Vibrations on Cold Start (Start up)

Purchased 2017 Elantra in mid June 2016 in Ontario, Canada.

Car seemed okay until Sept 2016, when it started to feel sluggish going up hills and slightly while accelerating. When the gas pedal was let off I felt the car tug either in gears downshifting or due to something else. Since Sept I have had cold start issues. When sitting for half a day/over night I can easily start my car but then vibrations last for 5-20 secs until the car warms up. RPM gauge doesn't show any issues.

Beg of issues: third week of Sept 2016 I had experienced a large surge after a cold start. (not just vibrations)

Sept 2016 to early Feb 2017: No surges, just vibrations that I consider NOT normal. Dealership said they are normal for all of the same models.

First week of Feb, on a super cold day, I felt pulses in my break pedal while stopped at a red light, while my car surged pretty hard but did not stall. I then called Hyundai about the issue and they mentioned that there was a thermostat stuck open recall and an ECM update called Control Logic Improvement (Performance) Update.

Feb 8: RECALL/CAMPAIGN: C0298 - Elantra ECM update control logic improvement completed and thermostat replaced. The dealership informed me that after doing an AVR test they found that my battery was a little low at 552 CCA when the battery is rated at 640 CCA and recharged it for me. The person I was speaking with also noted that if I let my car sit for too long the battery will drain. Meanwhile, I drive my car daily. Immediately after driving out of the dealership I had noticed that my gears were shifting faster, my car felt much more peppy and I didn't feel the tug when I was slowing down, or the slug when I accelerated. My cabin heat and engine also warmed faster.

Feb 23: Temperature outside goes from winter cold to 15C/60F and car surges and vibrates deeply and feels to want to choke out after cold startup.

Feb 24: Another large surge with vibrations.

In between all of these issues and at present vibrations upon cold start happen almost daily or a few times a week.

July 31: I brought my car in to see if they could find the issue again. Dealership calls and says that they can't find anything wrong with it in codes. I was not happy that my car was only checked for codes. I was not happy. I mentioned my battery needing a charge the last time it was there and so then they ran another AVR test. They then put in a new, stronger, battery with 760 CCA, and yet my issues of cold start vibrations still existed.

Aug 15: August 14 I experienced rough vibrations and was not happy. I called the dealership and they said to bring it in immediately. I recommended that they do physical tests and not just read for codes. I asked for a parasitic battery drain test and alternator test. Done! They also did an AVR test again. Battery test came back rated 760 CCA and measured 697 CCA, voltage 12.76V at 25C. Starter test "Cranking Normal" Voltage: 11.30V 0.0 amps and time: 546mS. Charging System Test came back as no problems found. No load: 14.43V and Loaded: 14.26V. Ripple test 41mV.

"have not been able to confirm any faults"
"no codes"
"checked and confirmed charging system is good"
"verified parasitic draw is normal (1-2 milliohms) after vehicle shut down"
"improved grounds in engine compartment"
"customer has requested customer service relations number"

The dealership did say that maybe an update will come out to correct the issues that they can't troubleshoot.

I am fed up with this. Again, today, my car was heavily vibrating upon cold start. The dealership basically chalked it up to these vibrations as being normal in these models. I have wracked my head and don't want to learn how to become a mechanic to fix my issues. Any help would be appreciated!

Thanks for reading

Heidi
heliosense is offline   Reply With Quote
Old 08-20-2017, 08:00 AM   #2
shorod
SHO Off
 
shorod's Avatar
 
Join Date: Jun 2004
Location: Cedar Rapids, Iowa
Posts: 10,588
Thanks: 64
Thanked 269 Times in 262 Posts
Re: 2017 Elantra Vibrations on Cold Start (Start up)

Has the dealer monitored some of the sensors real-time when the issue was present to see if everything is reading normal? For example, I would suggest they monitor the Engine Coolant Temperature (ECT) sensor, the Short Term Fuel Trim (STFT), Intake Air Temperature (IAT) sensor readings, Mass Air Flow (MAF) sensor flow (if your engine has a MAF sensor) and/or Manifold Absolute Pressure (MAP) sensor readings. They should compare these sensor readings against applicable measured or observed values to make sure they are reasonable. For example, they can use a IR thermometer to determine approximately what the ECT really is, they can use the same IR thermometer to get a feel for a realistic IAT. If the MAF or MAP sensor readings are jumping all over the place with no throttle input, that could suggest the sensor has an issue (although some of that could be due to the misfire or stumbling).

If the dealership has any real technicians (versus scan tool users) they should be able to help track this down, as long as they are able to duplicate the issue. Maybe they would be willing to drive your car home a few days while leaving you another similar model loaner. It would be interesting to see if the loaner vehicle really does do the same thing.

-Rod
shorod is offline   Reply With Quote
The Following 2 Users Say Thank You to shorod For This Useful Post:
heliosense (08-20-2017)
Old 08-29-2017, 12:38 PM   #3
heliosense
AF Newbie
Thread starter
 
Join Date: Aug 2017
Location: Hamilton
Posts: 5
Thanks: 5
Thanked 0 Times in 0 Posts
Re: 2017 Elantra Vibrations on Cold Start (Start up)

August 28, 2017: When I flicked my signal to turn the headlights went out for seconds. It went black outside. As I was making turns the lights came back on, until the signal flicked back into place and then the headlights went out again for a couple of secs.

I booked an appointment with the dealership and will post anything that comes back. I'm hoping it has to do with my outstanding issue posted above. Apparently a bad BCM can cause battery drain, of which could promote vibrations upon cold start.

Last edited by heliosense; 09-12-2017 at 11:18 PM.
heliosense is offline   Reply With Quote
Old 08-29-2017, 04:08 PM   #4
shorod
SHO Off
 
shorod's Avatar
 
Join Date: Jun 2004
Location: Cedar Rapids, Iowa
Posts: 10,588
Thanks: 64
Thanked 269 Times in 262 Posts
Re: 2017 Elantra Vibrations on Cold Start (Start up)

It sounds like the dealership should be confirming all the connections for battery and ground are clean and tight and that there are no loose fuses or possible fusible link splices.

As far as you are aware, has any aftermarket equipment been added to this car such as an alarm system, remote start, engine block heater, etc.? If so, inspecting the corresponding wiring for those items would be recommended as well.

-Rod
shorod is offline   Reply With Quote
The Following User Says Thank You to shorod For This Useful Post:
heliosense (08-30-2017)
Old 08-30-2017, 01:02 AM   #5
heliosense
AF Newbie
Thread starter
 
Join Date: Aug 2017
Location: Hamilton
Posts: 5
Thanks: 5
Thanked 0 Times in 0 Posts
Re: 2017 Elantra Vibrations on Cold Start (Start up)

No aftermarket products. I accepted to have a rust protector installed under the hood and the Elantra model with LED lights, of which was included upon new purchase at the dealership.

I wish I were dealing with someone like you at the dealership. lol Thanks for your leads. I had researched the ECT out online and see why you said that might be a possibility.

Since this new incident with the lights completely shutting off when switching the turn signal on/off, I kind of see where you're going with grounding, fuses and fuse link splices, after some research. This is time consuming! I appreciate you taking your time to help! I forgot to mention, I noticed that the headlight indicator went off on my dash when the lights completely shut off for secs after turn signal on/off. Mode: Auto lights.

Aug 29: Tonight, nothing wrong with signaling and headlights running normal. Though, car was not happy upon cold start. Car vibrated stronger and longer than usual=(few times to daily per week). I'm starting to worry that the lifespan of my car is going to be affected... depending on the issue. Maybe the ROUGH vibrations and slow battery drain are due to something that is or isn't isolated from my lights going out when signal is switched on/off.

Rod, I'm going in to dealership this Friday. Would you mind if I reference your posts? You are definitely more inclined to work with peoples, ask questions and troubleshoot than in my experience.

Thanks again!

Last edited by heliosense; 09-13-2017 at 08:20 AM.
heliosense is offline   Reply With Quote
Old 08-30-2017, 06:34 AM   #6
shorod
SHO Off
 
shorod's Avatar
 
Join Date: Jun 2004
Location: Cedar Rapids, Iowa
Posts: 10,588
Thanks: 64
Thanked 269 Times in 262 Posts
Re: 2017 Elantra Vibrations on Cold Start (Start up)

Quote:
Originally Posted by heliosense View Post
Would you mind if I reference your posts?
Not at all.

And the dealership should be willing to try anything they can to gain trust with their customers. It would likely pay off for them in the long run. These types of intermittent issues often are very difficult to troubleshoot since there are few opportunities to be looking in the right area at the precise time the issue happens. Since the vibrations seem to be getting more pronounced and more common as of recent, hopefully the dealership staff will have a better chance at being able to properly diagnose. While I have no doubt it's frustrating for you, especially with a new car, hopefully they'll get it taken care of soon and you'll get several years of reliable service from the car.

Best of luck!

-Rod
shorod is offline   Reply With Quote
The Following User Says Thank You to shorod For This Useful Post:
heliosense (08-30-2017)
Old 09-12-2017, 10:50 PM   #7
heliosense
AF Newbie
Thread starter
 
Join Date: Aug 2017
Location: Hamilton
Posts: 5
Thanks: 5
Thanked 0 Times in 0 Posts
Re: 2017 Elantra Vibrations on Cold Start (Start up)

Sept 2: Lights went off multiple times when using turn signal.
Sept 11: Again, lights turn off when signal engages
Sept 12: Lights turn off when right signal is engaged and disengaged.
(SEE VIDEO at the LINK BELOW)

I have not been to the dealership yet. I will post any updates after I do. I wanted to capture the signal/light issues on cam before going back. Car still vibrates pretty rough upon cold starts. Below is a link to the video I finally captured of my signal/light issues. Notice the console display when signalling and how erratic the lights are as well. Lights have stayed off longer (1-3 seconds max) than what is shown in video.

http://i.imgur.com/TPlLMCV.gifv

Last edited by heliosense; 09-12-2017 at 11:50 PM.
heliosense is offline   Reply With Quote
Old 10-10-2017, 12:00 AM   #8
heliosense
AF Newbie
Thread starter
 
Join Date: Aug 2017
Location: Hamilton
Posts: 5
Thanks: 5
Thanked 0 Times in 0 Posts
Re: 2017 Elantra Vibrations on Cold Start (Start up)

Thanks for your help! Issues were difficult? to troubleshoot and car was replaced. I do not notice issues in my 2018!
heliosense is offline   Reply With Quote
Old 10-10-2017, 06:52 AM   #9
shorod
SHO Off
 
shorod's Avatar
 
Join Date: Jun 2004
Location: Cedar Rapids, Iowa
Posts: 10,588
Thanks: 64
Thanked 269 Times in 262 Posts
Re: 2017 Elantra Vibrations on Cold Start (Start up)

Congratulations! I'm glad to hear your 2018 doesn't have the same issues and this worked out for you.

-Rod
shorod is offline   Reply With Quote
The Following User Says Thank You to shorod For This Useful Post:
heliosense (10-10-2017)
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
2017, elantra, hyundai, surges, vibrations
Go Back   Automotive Forums .com Car Chat > Hyundai > Elantra | Avante

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:12 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts