Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > Freestyle
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 01-31-2018, 04:01 PM   #1
cptjacksprw
AF Newbie
 
Join Date: Nov 2014
Location: Maricopa, Arizona
Posts: 4
Thanks: 2
Thanked 0 Times in 0 Posts
Cool 2006 Freestyle Acceleration Issue

Hello everyone,

This kinda seems like a dead forum but im willing to try it out.

I have a 2006 Freestyle Limited 2wd, a couple months ago i noticed that under moderate acceleration it seemed to hesitate and seem like it was cutting out or chugging. Well now its very noticeable, i figured the easiest and most likely culprit was the fuel filter so I replaced that last weekend. It unfortunately did not correct the issue. I took it to Autozone yesterday and the guy there said it wasnt throwing any codes and the check engine light has never come on. So now ive got about 100 different things that could be wrong with it running through my head. I hope to get it to my mechanic this weekend. Does anyone here have any ideas? Tune up, fuel pump or God forbid the transmission? im a little hesitant to blame the transmission because ive noticed a random rough idle when sitting in traffic especially with the a/c on but maybe its just wishful thinking..

It doesnt seem to do it as much in the morning when the temps are cool, on my way home from work, sitting in traffic its pretty bad...

Last edited by cptjacksprw; 01-31-2018 at 04:04 PM. Reason: additional info
cptjacksprw is offline   Reply With Quote
Old 01-31-2018, 05:11 PM   #2
65comet
AF Enthusiast
 
65comet's Avatar
 
Join Date: Aug 2004
Location: Porter, Indiana
Posts: 810
Thanks: 7
Thanked 67 Times in 65 Posts
Re: 2006 Freestyle Acceleration Issue

I'm guessing it is a V6. Ford occasionally has a problem with the catalytic converter clogging up. This then causes a back pressure and the engine just doesn't want to run. That is what I would check for if there aren't any codes.
65comet is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
chugging, hesitation
Go Back   Automotive Forums .com Car Chat > Ford > Freestyle

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:46 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts