Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Nissan > Primera | G20 > General
General news, articles, other.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 03-06-2004, 10:21 AM   #1
TFL
AF Newbie
 
Join Date: Mar 2004
Location: cranston, Rhode Island
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
any ideas on this g20 problem

so here's the deal;

i just got a g20 from my brother and its pretty tight, few little problems and one that has me stumped. when the car is warmed up it will stall out. it only occurs when the car is completeley stopped, be it in neutral or in 1st gear. the rpm's will start to drop under a 1000 then pop up then drop down to 200 or so and then pop up and eventually on the downstroke the car stalls out. so i replaced the plugs cause they were due, as was the fuel filter, i also did a fuel injector cleaning. it was still doing it. so i bumped up the idle a bit, it idles at about 1400 now and i dont get the stalling but it doesn't seem like a lasting solution. i'm thinking maybe fuel pump or o2 sensor. anyone seen this before? any advice would be apreciated, it has me somewhat baffled and i'd hate to bring it somewhere, you know how expensive the repairs are at luxury car dealers. thanks
TFL is offline   Reply With Quote
Old 03-14-2004, 06:01 PM   #2
MattBG20t
AF Newbie
 
Join Date: Mar 2004
Location: Boston, Massachusetts
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Re: any ideas on this g20 problem

This could be a number of things. The first thing I'd look at is the Idle Air Control valve (IAC). Have it cleaned out, it's not expensive.
MattBG20t is offline   Reply With Quote
Old 03-14-2004, 10:02 PM   #3
TFL
AF Newbie
Thread starter
 
Join Date: Mar 2004
Location: cranston, Rhode Island
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Re: any ideas on this g20 problem

doin it tomorrow, we shall see
TFL is offline   Reply With Quote
Old 05-14-2004, 08:00 PM   #4
urasula
AF Regular
 
Join Date: May 2001
Location: Vancouver
Posts: 102
Thanks: 0
Thanked 0 Times in 0 Posts
just like u said. i think it may be the fuel pump or the o2 sensor. i had to replace a fuel pump on my p10 last year.
urasula is offline   Reply With Quote
Old 08-23-2004, 07:43 PM   #5
G-ealousy
AF Enthusiast
 
G-ealousy's Avatar
 
Join Date: Apr 2002
Posts: 143
Thanks: 0
Thanked 0 Times in 0 Posts
Re: any ideas on this g20 problem

This is old but, for future refrence, always start with a FULL tune-up, and then go from there...
__________________

26,122 miles as of March 3, 2004
My real name is Kaizer Soze, but my friends call me Nick...
G-ealousy is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Nissan > Primera | G20 > General

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:25 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts