Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Engineering/Technical
Engineering/Technical Ask technical questions about cars. Do you know how a car engine works?
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 12-13-2009, 10:56 AM   #1
grewag
AF Newbie
 
Join Date: Dec 2009
Location: Brighton, Illinois
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Auburn posi unit

I bought a used 1970 8.2/10 bolt Auburn posi unit and had it installed on my 69 firebird. This units does not use clutchs. A new install kit was used with my existing ring and pinion (3.23). When I drive it, barely moving sometimes, it makes a clunking sound even with the clutch in. I notice it mainly when I am pulling it in and out of my garage going straight. The u-joints seem to look OK. Could it be the type of oil the mechanic used. I believe he used Synthetic with anti slip additive. Does anyone have any thoughts?

Thanks

Last edited by grewag; 12-13-2009 at 11:55 AM.
grewag is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Engineering/Technical

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:22 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts