Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Suzuki > Sidekick
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-16-2011, 05:30 PM   #1
julius415
AF Newbie
 
Join Date: Oct 2011
Location: kailua kona, Hawaii
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
97 suzuki sidekick p0171 code and rough idle. Help!

Hey everybody didnt see any posts regarding my problem so here it goes.

I have a 1997 suzuki sidekick sport 1.8l and 108k. Some months ago the car started having a rough idle. When ever i came to a stop light the rpm would fluctuate up and down and the car would almost stall out. It progressively got worse and the car did start stalling when at a stop. During one of the rough idling episodes i decided to turn off the car, wait for the stop light to turn green, then turn it back on. But when i went to turn on the car, it wouldnt turn on, in fact not even the dash lights light up. So i called toyota service (they do suzuki's in hawaii), and had them check it out. Turns out during all the rough idling shaking a hose had come loose and spilled ( i think power steerin fluid) all over the alternator, which fried it and i ended up running the battery dry. They also told me my computer was fried. Had all of that replaced and the car turned on but still rough idle. They told to change maf, did and no change, then iac, did also and no change, then they had the nerve to tell me that the whole throttle body had to be changed. I argued they gave me the run around, so i jus paid and got out of there.
I went for a 2 month trip, and while i was gone my friends was using my car. Turns out a oil leak started and the engine ran with very low oil for a while. I came home it was running horribly. Took the engine apart saw that a couple of piston rings were broken and had scratched up the cylindes. Had machine shop hone cylinders, install oversize pistons, and check head. Got everything checked and ready and put it back together. Car is running alot better almost to full power, but now the rough idling returned.
I cleaned egr valve, checked for vacuum leaks the propane method didnt find any( first time doing it so i am not sure if i did a good job at it). But visually inspecting all hoses look good ( no cracks). There was a crack on exhaust manifold and i put thermosteel on it. Seems to be holding and i cant feel and hear any air coming out. I did notice that at first car runs great and no rough idling, but once it warms up the problems start. Also when i reset the ecm things get realy bad.
Any help would be greatly appreciated, i have been trying to figure this out on my own without going to costly mechanics. Also the ecm pulls up a p0171 code, and a p0420 code but i dont have a catalytic converter so it think that is why.
i checked the voltage for o2 sensor and had a constant reading below .45V, which in the haynes book says it is defective. but when i really gas the car i shoots up to .8V. So i am thinking it is not defective but i just get a constant reading below .45V because the mixture is lean. right? and therefore i am getting the p0171 code.
Also since no codes for any of the sensors are coming up it is safe to say that they are working?
anyways hope somebody can help thanks
Julius
julius415 is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with 97 Villager rough idle dscott1838 Villager 12 05-09-2009 10:34 AM
P1345 Code and Rough Idle HeyRobi Problem Diagnosis 1 09-05-2007 07:12 PM
P0300 Code and Rough Idling bedwar2 Malibu 4 02-07-2007 05:11 PM
P0171/P0174 Codes and rough idle cebell Windstar 3 11-05-2006 01:30 PM
99 c2500 hard start and rough idle ....HELP! n8zdogg C/K 1 07-17-2006 04:42 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Suzuki > Sidekick

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:59 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts