Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Saab > 900
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 02-12-2014, 01:53 AM   #1
islandman7
AF Newbie
 
Join Date: Jun 2006
Location: Victoria, BC
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
1994 SAAB 900 Starting problem

My 94 2.3 SAAB 900s NG will not start. I switch the ignition on and the dash board lights up as normal, one click further to start the engine and all I get is click, click, click and the dash lights flashing. I have been out about a week, when I come back home and tried start, this happens. Battery read 12,5v. Anyone got any idea what the problem is?
Thanks
islandman7 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Saab > 900

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:19 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts