Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Nissan > 240Z | 260Z| 280Z | 300ZX (Past Z Cars)
240Z | 260Z| 280Z | 300ZX (Past Z Cars) The original Z cars - ones that started it all.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 12-28-2012, 01:06 AM   #1
Andrew Barrett
AF Newbie
 
Join Date: Dec 2012
Location: Lake Point, Utah
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs down 1983 Datsun 280zx misfire!! PLEASE HELP!

Hey guys I am currently new to these forums, but I need some help with my Datsun 280zx, here's what's going on, one day I was driving down the road my car was running fine then all of a sudden it started running horrible like it was missing. Here's the things I've checked and done but still runs the same:
I've checked the spark plugs to see how it was running either rich or lean, it was normal. So I checked the spark plug wires with cylinder deactivation canceling each cylinder out at a time to see which wire was bad.. None were I even changed one of the spark plug wires still ran bad. So I checked & cleaned the EGR valve also changed the PCV valve.. Still ran bad, next up I thought it had to be a fuel problem so I checked all the injectors & they are operating properly. I haven't had a chance to check for fuel pressure but I just changed the regulator so I doubt it's that. It has a rough idle in park & in gear but seems to run fine until it shifts into 3rd gear then it runs horrible and doesn't want to accelerate but it still downshifts & has the same power it did before it was running like this. I have put fuel injector cleaner in so we will see if that makes a difference. I'm really hoping its not a compression issue if so looks like I'm gonna have a unpredicted rebuild at the worst possible time.
PLEASE HELP!! Thanks for any help or suggestions.
Andrew Barrett is offline   Reply With Quote
Old 07-03-2013, 10:19 AM   #2
Admaker22
AF Newbie
 
Join Date: Jun 2013
Location: Hickory, North Carolina
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1983 Datsun 280zx misfire!! PLEASE HELP!

I feel your pain..I have a 1981 280zx turbo that does basically the same thing..I have replaced the mass air flow sensor , plugs , plug wires, fuel filter , had the Injectors cleaned and when I punch it , it just pops and sputters...if you find a solution , let me know and I will do the same...
Admaker22 is offline   Reply With Quote
Old 08-31-2013, 06:24 PM   #3
Cammy_01
AF Newbie
 
Join Date: Jul 2004
Location: Havelock, North Carolina
Posts: 58
Thanks: 0
Thanked 1 Time in 1 Post
Re: 1983 Datsun 280zx misfire!! PLEASE HELP!

check all connections including battery terminals and that everything is grounded well. These cars are getting very old and most of the issues I have ever seen is always a bad connection and or bad ground.
Cammy_01 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Nissan > 240Z | 260Z| 280Z | 300ZX (Past Z Cars)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:42 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts