Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Suzuki > Sidekick
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 08-15-2008, 08:27 PM   #1
seashell33912
AF Newbie
 
Join Date: Aug 2008
Location: n. ft. myers, Florida
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy 89 Suzuki Sidekick isn't getting spark

My suzuki sidekick 4X4 is not getting any spark. We have tried changing the fuel filter, ignition coil and plug wires and still nothing!! Does anyone have any ideas what else it could possibly be? All I know is that I was driving it the other day and all of a sudden it started to lose its power. My rpms dropped bit it never over heated. It did stall on me once but I got it to fire up and I made it to where I needed to go,but it hasn't started since. Any ideas would be helpfull. Please HELP. He's my baby and I miss taking the top off and just cruising around.It has a 1.6L standerd in it.


Thanx!!!
seashell33912 is offline   Reply With Quote
Old 09-01-2009, 01:28 PM   #2
MAXIMUS_PRICO
AF Newbie
 
Join Date: Jan 2004
Location: SAN JUAN
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 89 Suzuki Sidekick isn't getting spark

Quote:
Originally Posted by seashell33912 View Post
My suzuki sidekick 4X4 is not getting any spark. We have tried changing the fuel filter, ignition coil and plug wires and still nothing!! Does anyone have any ideas what else it could possibly be? All I know is that I was driving it the other day and all of a sudden it started to lose its power. My rpms dropped bit it never over heated. It did stall on me once but I got it to fire up and I made it to where I needed to go,but it hasn't started since. Any ideas would be helpfull. Please HELP. He's my baby and I miss taking the top off and just cruising around.It has a 1.6L standerd in it.


Thanx!!!
bad coil,bad wires,bad spark plugs could be lots of things check the basic stuff the post more details
MAXIMUS_PRICO is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Suzuki > Sidekick

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:09 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts