Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Lincoln > Town Car
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 03-23-2009, 01:00 PM   #1
91lincoln
AF Newbie
 
Join Date: Mar 2009
Location: Springfield, Missouri
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to 91lincoln
Unhappy 91 Lincoln TownCar Signature Series - No power

Hello,

I have a 1991 Lincoln TownCar Signature Series , it recently stoped working all together and I think I know what caused it , but not sure what to do or check.

Recent events: I installed a Kenwood deck , worked fine for a few days , I turn the corner to pull into my driveway and start hearing my acceleration through the speakers. The engine rev and noise was in sync with the noise coming from the speakers.

Once I put the car in park it lost complete power. I can't even get an ounce of power from a jump , no lights etc.

What could be the cause of no power? I thought about it being the battery , but from the neighbor giving me a jump the car should have gotten some sort of power from his battery at least.



If you need more information to help come up with a solution , just ask me and I can reply asap.

Thanks in advance for any helpful comments.
91lincoln is offline   Reply With Quote
Old 03-23-2009, 09:12 PM   #2
junk yard doggie
AF Enthusiast
 
junk yard doggie's Avatar
 
Join Date: Sep 2005
Location: Peasticks, Kentucky
Posts: 742
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 91 Lincoln TownCar Signature Series - No power

Check your bat connections.
__________________
Mike aka JYD
junk yard doggie is offline   Reply With Quote
Old 03-24-2009, 12:20 PM   #3
91lincoln
AF Newbie
Thread starter
 
Join Date: Mar 2009
Location: Springfield, Missouri
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to 91lincoln
Re: 91 Lincoln TownCar Signature Series - No power

Quote:
Originally Posted by junk yard doggie View Post
Check your bat connections.
Battery cables , connections etc are all fine. I've looked at the fuses , according to the guy at autozone if the fuse is blown or bad the wire in the middle would be broken. They all looked fine to me.

Next thing I can think of is having the battery tested
91lincoln is offline   Reply With Quote
Old 03-24-2009, 04:08 PM   #4
Kitt1993
AF Regular
 
Kitt1993's Avatar
 
Join Date: Oct 2007
Location: Vero Beach, Florida
Posts: 385
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 91 Lincoln TownCar Signature Series - No power

Have the battery checked, and the fuse able links.
__________________
Nick names for my Car....

Abe Lincoln, opcorn:


The President,


Lucky Number 5
Kitt1993 is offline   Reply With Quote
Old 03-25-2009, 05:21 PM   #5
Bearfoot
AF Regular
 
Join Date: Mar 2007
Location: Parma, Idaho
Posts: 166
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 91 Lincoln TownCar Signature Series - No power

If a fuse is bad the wire does not have to be broken. That is a common fallacy. Use a continuity tester, if nothing else. Often a fuse will look good but won't be. The same applies to light bulbs. I just changed one in my light bar that looks good but won't light. Put in a new bulb and it lights right up.
__________________
Stan
'98 Lincoln Towncar - white 100k
'08 Mercury Grand Marquis - maroon 30k
'98 Dodge 3/4 ton, Cummins Diesel, 4 x 4, 4 door, extended cab, long bed. 140k
Bearfoot is offline   Reply With Quote
Old 04-21-2009, 09:39 PM   #6
91lincoln
AF Newbie
Thread starter
 
Join Date: Mar 2009
Location: Springfield, Missouri
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to 91lincoln
Re: 91 Lincoln TownCar Signature Series - No power

Thanks everyone , the problem was the Power Distribution Center was dead. Battery was fine as well as the fuses.
91lincoln is offline   Reply With Quote
Old 04-22-2009, 07:05 AM   #7
junk yard doggie
AF Enthusiast
 
junk yard doggie's Avatar
 
Join Date: Sep 2005
Location: Peasticks, Kentucky
Posts: 742
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 91 Lincoln TownCar Signature Series - No power

What was the problem with the power distribution center?
__________________
Mike aka JYD
junk yard doggie is offline   Reply With Quote
Old 04-22-2009, 12:46 PM   #8
91lincoln
AF Newbie
Thread starter
 
Join Date: Mar 2009
Location: Springfield, Missouri
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to 91lincoln
Re: 91 Lincoln TownCar Signature Series - No power

The mechanic said the center wasn't getting any power to it. A wiring problem somewhere. Also the stalling out problem was a vacuum leak in manifold. All in all $300 to fix both , and then it came out with a new problem ( Gotta love it ) The AC and heat does not blow.
91lincoln is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
lincoln, no power, town car, won't start
Go Back   Automotive Forums .com Car Chat > Lincoln > Town Car

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:47 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts