Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mitsubishi > Endeavor
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 03-29-2009, 09:43 PM   #1
vedermania
AF Newbie
 
Join Date: Mar 2009
Location: Cleveland, Ohio
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
No air out of front defogger

I have a 2007 Endeavor with the following problem:

Air does not blow out of the front defogger to defog the windshield. You hear it blowing, but it is not coming out. I have switched the knob to change the airflow direction from the cabin to the cabin/feet to the feet only to the defogger/feet and the defogger only. Air blows out of all locations normally except when the front defogger is selected.

What / where should I be looking to fix this? What operates the airflow?

Any help would be greatly appreciated.
vedermania is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Mitsubishi > Endeavor

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:30 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts