Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Pontiac > Trans Sport
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 11-14-2010, 01:55 PM   #1
Rickkins
AF Newbie
 
Join Date: Jan 2008
Location: Montreal
Posts: 46
Thanks: 3
Thanked 0 Times in 0 Posts
'95 trspo, 3.8L, No power brakes....

Brakes still work, but no power brakes.

Any thoughts..??

Thanks.
Rickkins is offline   Reply With Quote
Old 11-14-2010, 03:12 PM   #2
Blue Bowtie
Registered Offender
 
Blue Bowtie's Avatar
 
Join Date: Mar 2006
Location: Rural
Posts: 5,985
Thanks: 3
Thanked 247 Times in 243 Posts
Re: '95 trspo, 3.8L, No power brakes....

Check the simple things, like the vacuum source to the power booster, from teh intake to the booster fitting. Also inspect the vacuum check valve on the booster (right where the vacuum line connects), and try to listen for any hissing noises inside the vehicle when the brake is applied.

The information I have indicates that HydroBoost was not an option on the Trans Sport, so you should have a plain vacuum power booster.
__________________
Permanent seat assignment on the Group W bench...
Automotive Forums Survival Guide
Blue Bowtie is offline   Reply With Quote
Old 11-15-2010, 09:27 AM   #3
Rickkins
AF Newbie
Thread starter
 
Join Date: Jan 2008
Location: Montreal
Posts: 46
Thanks: 3
Thanked 0 Times in 0 Posts
Re: '95 trspo, 3.8L, No power brakes....

Quote:
Originally Posted by Blue Bowtie View Post
Check the simple things, like the vacuum source to the power booster, from teh intake to the booster fitting. Also inspect the vacuum check valve on the booster (right where the vacuum line connects), and try to listen for any hissing noises inside the vehicle when the brake is applied.

The information I have indicates that HydroBoost was not an option on the Trans Sport, so you should have a plain vacuum power booster.
After a quick google image search, I poked my head and found what mentioned, saw a disconnected hose, popped her back on and we're braking again...

Thanks!!
Rickkins is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
'95 Transport 3.8L Tapping Noise!! :( yellowfiero Trans Sport 4 04-11-2009 01:41 AM
'95 88 3.8L intermittent stalling/missing -- No codes RickyJP Eighty Eight 4 12-04-2008 08:32 AM
Engine sputters and stalls - '95 Transport 3.8L More Details Inside. yellowfiero Trans Sport 3 06-01-2008 10:09 AM
Difficulty level for front bearing replacement?? '95 Transport 3.8L yellowfiero Trans Sport 15 12-18-2006 06:36 PM
92 Taurus 3.8L Power Steering gjimene2 Taurus | Taurus Wagon 3 08-11-2004 06:15 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Pontiac > Trans Sport

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:18 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts