Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Nissan > Primera | G20 > General
General news, articles, other.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 11-11-2003, 04:22 PM   #1
Zuko
AF Newbie
 
Join Date: Nov 2003
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Angry stalling problems 2.0 TD

I have a '97 GX TD. When I start the car it will idle normally for a while, then as the engine warms up it starts to run erratically and then stalls. Even when the engine is warm and I have driven for a few miles the engine will cut out when idling. After a good bit of driving the engine will idle normally, but this usually takes a long time. What could be causing this? I have changed the air and fuel filters and it recently had a new battery. I was told that it could be the glow plugs but this doesn't seem right as it still cuts out even after the temp gauge shows hot.

Any help would be greatly appreciated.
Zuko is offline   Reply With Quote
Old 01-15-2004, 09:51 AM   #2
edd_o_brain
AF Newbie
 
Join Date: Jan 2004
Location: test
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Air mass meter?

We have had a spate of problems with ours and it is now thought that is needs an upgrade to the diesel pump.

Our car is a 97 SLX 2.0 TD. Ours fails to start or smokes mainly when warm, but sometimes when you start it from cold, there is a certain point on the temp guage when if you let it idle it sometimes cuts out.
edd_o_brain is offline   Reply With Quote
Old 12-11-2004, 09:42 AM   #3
marky04
AF Newbie
 
Join Date: Dec 2004
Location: Southport
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
It's a replacement pump that's required - not an upgrade.

Mine was doing exactly the same thing and I'm waiting for a remanufactured pump from Feather's in Halifax to be fitted.

More specifically, its the governor that has failed, causing the difficult starting as well as RPM surges which could end up killing the engine if not checked.
marky04 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Nissan > Primera | G20 > General

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:07 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts