Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Land Rover > Range Rover | Range Rover Sport | Evoque
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 12-07-2008, 10:09 PM   #1
mishka7
AF Newbie
 
Join Date: Dec 2008
Location: philadelphia, Pennsylvania
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
03 range rover torque clutch converter p0741

bought used 2003 range rover with 65k miles,, drove it for a week and now i get service engine soon.. my mechanic looked at it and told me that it brings up code for Torque Clutch Converter - P0741. Car was driving Ok before and now when it shifts, makes a little noise. I think that it is a Converter went dead. Anyone knows who can fix it or if I just should take it to a dealer and let him look at it. Also, how much this fix can run me parts and labor?
any info is appriciated.
thanks in advance
mishka7 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Land Rover > Range Rover | Range Rover Sport | Evoque

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:48 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts