Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mercedes-Benz > ML-Class | GL-Class
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 07-06-2017, 12:57 AM   #1
Reeeeeen
AF Newbie
 
Join Date: Jul 2017
Location: Edmonton
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
ML 320 not starting and pouring out gas when trying to start it

It was fine for the longest time . I bought it and haven't driven it yet and a month later I go to start it and it starts pouring out gas from the back side where the gas tank is when ever I try to start it. Car doesn't turn on only cranks. It doesn't stop pouring until I stop turning the key. And only pours when I try to turn it on. I have no clue where it's coming from and I can't take t to a mechanic cause it doesn't start. The cars pretty old year 2000. Not really worth putting money in to fix but I need to sell it or use it to get to school. Any ideas what can cause this and how I can get it fixed. Got a couple mechanics willing to come look at it but I'm not sure if it's going to cost a a lot or not. I'd rather sell as is to some one who knows how to fix it for less then what I was intending on asking for .
Any ideas could help greatly.
Reeeeeen is offline   Reply With Quote
Old 07-06-2017, 06:05 AM   #2
Stealthee
Your worst nightmare
 
Stealthee's Avatar
 
Join Date: Oct 2004
Location: Smithfield, Pennsylvania
Posts: 5,234
Thanks: 4
Thanked 110 Times in 107 Posts
Re: ML 320 not starting and pouring out gas when trying to start it

Sounds like a fuel line is broken or disconnected.
__________________
Stealthee is offline   Reply With Quote
Old 07-06-2017, 10:21 PM   #3
Reeeeeen
AF Newbie
Thread starter
 
Join Date: Jul 2017
Location: Edmonton
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: ML 320 not starting and pouring out gas when trying to start it

Quote:
Originally Posted by Stealthee View Post
Sounds like a fuel line is broken or disconnected.
Is this a expensive fix?
Reeeeeen is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Mercedes-Benz > ML-Class | GL-Class

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:34 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts