Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Honda > Odyssey
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 02-08-2012, 01:57 PM   #1
ArtChee
AF Newbie
 
Join Date: May 2006
Location: Sarasota, Florida
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
2006 Navigation System problem... HELP!

Recently purchased a very nice 2006 ODYSSEY Tourning with Nav Sys. Was checking out the Nav System, and wanted to see IF the previous owner had maybe up-graded the GPS MAP. Found the DVD slot for the Nav Sys under the driver's seat and ejected the disc. Found it to be the 2005 version - so not up-graded, and data is now 7 years old.

PROBLEM: When re-inserted the disc, the nav system (nor backup camera) no longer function. I get message on screen "Please check disc". Nothing apparently wrong with disc. What am I missing to get this system working again? No "Trouble shooting" in manual that I can find.

Any input will be appreciated.
ArtChee is offline   Reply With Quote
Old 03-31-2012, 09:03 AM   #2
ArtChee
AF Newbie
Thread starter
 
Join Date: May 2006
Location: Sarasota, Florida
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2006 Navigation System problem... HELP!

UP-DATE: I always seem to run into "odd" problems. Apparently no one on this forum has experienced anything like this, as there have been no replies in almost 2 months. For those who have stopped in, here's more to the story (most of which I posted in a more recent thread).
The problem was caused when I inserted a COPY of the latest version (v.4.9A) of the "White" GPS DVD. Apparently the system detected the disc as "illegal" and aborted the install/load. When I went back to the OEM "White" v.4.31 disc it would not re-load either. Learned that once you up-grade you cannot go back to an earlier version. In trying to load the v.4.9A, the system evidently recorded the attempt to up-grade and has locked out my original disc.
BEWARE of unauthorized DVD disc in Honda Navigation System. The system is apparently much more sensitive than a PC.
ArtChee is offline   Reply With Quote
Old 10-27-2012, 07:32 AM   #3
ArtChee
AF Newbie
Thread starter
 
Join Date: May 2006
Location: Sarasota, Florida
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2006 Navigation System problem... HELP!

For the benefit of any one browsing this subject - that I stood alone in - the problem was FINALLY solved.

When attempting to upgrade the GPS data with the "refurbished" DVD purchased online, as it was uploading the new data the navigation screen said "WARNING - do not turn engine off during this process" (or something like that). It SHOULD have said, "WARNING - do not turn engine off OR ON during this process." I did not have the engine running, and figured it SHOULD be running, so I cranked the engine during the upload. The power surge disrupted the upload, and apparently "fried" a circuit board in the DVD drive (under the driver's seat).

The local Honda dealer could not determine the problem and wanted $2,649.00 to REPLACE the Nav. Sys, Long story short - I made numerous inquiries, and had a local automotive custom audio shop check it out. They called the manufacturer & learned the problem was with the DVD drive, and wanted $470.00 to remove the drive and send to the manufacturer for repair. I removed the drive, and sent it with my check for $358.00 to ALPINE ELECTRONICS in Torrence CA for repair. Took about 6 weeks.

After reinstalling the DVD drive - ALL IS LIKE NEW AGAIN with the updates: CLOCK is restored to accurate time; COMPASS on instrument panel is restored; BACK UP CAMERA is restored. AND... map data appears to be up to date.

This system's map graphics are way too basic. It routes me 22 miles out of my way on my trip from NC to FL thru Orlando & past DisneyWorld where the traffic can be horrific, as it stays on the InterState. But I don't rely on it completely - I plan my own routing. But there are so many things I like on this system over the small screen stand alone units.
ArtChee is offline   Reply With Quote
Old 08-22-2013, 08:13 PM   #4
luvauto
AF Newbie
 
Join Date: Aug 2013
Location: Rochester Hills, Michigan
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2006 Navigation System problem... HELP!

Hi ArtChee,
I am having similar problems. In my used 2006 odyssey, i originally had V 4.13C disc. I then inserted a newer DVD from my friend's 2010 odyssey. I think it stopped half way and now it keeps showing me 'please check your disc'. Since then i have bought 2013 disc from Navtaq and that didn't fix the problem. I have removed the fuse and put it back and that didn't work either.
Is there a way to fix this issue without sending unit to Alpine for repair?
thanks
luvauto is offline   Reply With Quote
Old 08-22-2013, 11:09 PM   #5
ArtChee
AF Newbie
Thread starter
 
Join Date: May 2006
Location: Sarasota, Florida
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2006 Navigation System problem... HELP!

Quote:
Originally Posted by luvauto View Post
Is there a way to fix this issue without sending unit to Alpine for repair?
I tried long and hard to find the way. In my case, I "messed up" the DVD drive when I inserted a new DVD and started it without the engine running. A message came up "Do not turn engine off". So... I figured it needed to be ON, so while the DVD was loading, I started the engine. That apparently caused a surge and ruined the drive. The only course at that point was to replace it, have it fixed, or - as I did - send it to Alpine for repair.

Your scenario sounds much like mine. I would have thought the latest version of the DVD would have worked. In my case the damage was done with the 3rd party disc that I was using when I started the engine while it was loading. I ordered the OEM disc from Honda, and it would not load.

I had to confirm that the problem was, in fact, in the DVD drive. I checked with 2 Honda dealers. One referred me to a local automobile radio shop who checked with Alpine as to how to fix it & said it needed to be sent to them for repair; the other had no idea & quoted me $2,640.00 to replace the system. A friend of a friend recognized the problem right away and gave me the address to send the drive to.

It was tedious to remove the DVD drive from under the driver's seat, and took about 5 or 6 weeks (waiting on parts from Japan) to get it back. BUT... it all works like new now.
ArtChee is offline   Reply With Quote
Old 08-23-2013, 12:18 PM   #6
luvauto
AF Newbie
 
Join Date: Aug 2013
Location: Rochester Hills, Michigan
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2006 Navigation System problem... HELP!

Thanks for prompt response. I don't remember but I might have done the key cycle too. I will send the unit to Alpine for repair.. thx agian
luvauto is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
Help With widow kospotts Dakota 2 02-12-2012 12:22 PM
2001 Grand Cherokee Limited intermittant starting problem snorander Grand Cherokee | Grand Cherokee SRT8 3 02-08-2012 09:10 PM
1999 Buick Century transmission electrical problem Herb1949 Century 0 02-08-2012 12:55 PM
Power door lock motor problem onit Windstar 0 02-08-2012 10:32 AM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Honda > Odyssey

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:12 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts