Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > Expedition
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 07-28-2011, 04:34 PM   #1
erichzeppelin
AF Newbie
 
erichzeppelin's Avatar
 
Join Date: Feb 2010
Location: USS Ranger CV-61, Alaska
Posts: 30
Thanks: 3
Thanked 0 Times in 0 Posts
Exclamation Window washer pump.................

My window washers stopped working front and rear, I opened the the washer fluid box, and found the pump was clogged with something that look's like snot. I cleaned it out, filled with new fluid, used a small piece off wire to make sure the jets were clear, and still nothing. I can hear the pump running, but I'm getting nothing. Any Idea's?
erichzeppelin is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
'95 Estate Washer Pump...No Werkee slickandrews Roadmaster 4 02-24-2010 11:29 PM
Driver side window operation and washers are out Moonzuk Sierra 0 06-16-2009 09:25 AM
Window Washer Pump? jmiller07 Pathfinder | Terrano | QX4 | Xterra | Patrol | Safari | X-Trail 2 09-03-2007 01:37 PM
front window washer pump not working soaper Montana/Montana SV6 3 10-07-2006 08:54 PM
93 windsheild washer pump won't pump bnelson1020 Sonoma | S-15 2 01-05-2005 10:31 AM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Ford > Expedition

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:18 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts