Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Engineering/Technical
Engineering/Technical Ask technical questions about cars. Do you know how a car engine works?
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 06-23-2017, 09:09 AM   #1
Biggage7j
AF Newbie
 
Join Date: Jun 2017
Location: Churchville, New York
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation 0153 Code Nightmare, Can't Find the Issue! Please Help.

Vehicle is a 2002 Chevrolet Avalanche 1500 4x4 5.3L V8 With Aftermarket Flowmaster Headers and Exhaust.

Getting a P0153 Slow Response Code Bank 2 Sensor 1 about 10 miles after clearing the code.

Initially I replaced the o2 sensor in question with a Denso branded one. Cleared code, and the same code came back. So to be sure it wasn't a faulty o2 sensor I got a new one of same brand. Code came back again after clearing.

Which lead me to check the wiring leads all the way up to the harness for shorts and the wiring was fine. Also checked for exhaust leaks and found a bolt loose at the flange just in front of the o2 sensor in question. So I thought I had found the issue. Cleared the code and sure enough the code was back after 10 miles.

We then proceeded to do a vapor smoke test of the vacuum and found a rather large leak at the 2 cylinder intake port gasket. So I had that replaced. Sure enough the code came back on 10 miles down the road after this.

Had a friend with a computer take a look at some live data while it was running and looked at the o2 switching and said that was switching properly as it should be. However when looking at cylinder misfires number 6 cylinder would misfire about 50 times at 1500 rpms within 5-10 seconds. Which had us thinking since that's the same bank as what the code was for maybe it's seeing that as a vacuum leak causing the 0153 code at the o2. So we changed spark plug just in case and swapped plug wires and coils while testing the misfires and nothing made the number 6 cylinder not misfire. Until we swapped the coil leads, at that point number 6 had 0 misfires and the misfires jumped to number 2 cylinder.

So to us, that shows us number 6 is capable of firing fine, ruling out valve issues or compression issues, it's something else. Keep in mind there is no code being thrown for misfiring, just the 0153 for the o2 sensor.

We also swapped out the MAF sensor to be sure it wasn't that either.

For shits and giggles, we loosened the flange on the exhaust on that bank to see if the cat might be plugged and could be causing a misfire for some reason as sure enough loosening the exhaust just a half inch made the misfires practically disappear. So I tried driving like that to see if we could get the check light to stay off long enough to get the vehicle inspected at least. SURE ENOUGH LIGHT COMES ON AFTER 10 Miles.

I'm at my wits end, don't know what else to try besides looking at the fuel pressure. But I feel like if it was a fuel pressure issue, the codes would be thrown on both banks not just bank 2. So idk, please help lol. I might add the truck seems to run okay even with cylinder 6 misfiring so often so it's quite weird, but figured a misfire on the same bank as the nightmare code for that bank is too weird to be a coincidence.
Biggage7j is offline   Reply With Quote
Old 06-23-2017, 03:00 PM   #2
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,420
Thanks: 9
Thanked 309 Times in 303 Posts
Re: 0153 Code Nightmare, Can't Find the Issue! Please Help.

__________________
maxwedge is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Engineering/Technical

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:56 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts