Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Traverse
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 11-18-2019, 10:48 PM   #1
ChevMali99
AF Regular
 
Join Date: Oct 2008
Location: NYC, New York
Posts: 124
Thanks: 1
Thanked 0 Times in 0 Posts
Chevy Traverse 2009 - Testing why the low heat?

Hello - As the title alludes to, my 2009 Traverse puts out very anemic heat in the cabin.

I scoured the web for videos on what could be the problem and a few potential culprits were cited. But first, let me go into what is actually happening.

As soon as I turn the ignition on, the radiator fans are blowing. Though I find that strange, several GM sites say it is normal operation, eventhough having the fan constantly on, in the winter no less, keeps the operating temperature way below optimal operating conditions for a longer period of time. In other words, it takes longer for the car to warm up and give proper cabin heat.

I checked the dexcool levels in the reservoir and the radiator, both were topped full. I moved on to replacing the temp sensor and the problem remained - It's no fun to drive in a less than warm cabin.

Moved on to the HVAC Blend Door Actuator, as many videos suggested but before committing to this solution, I took a look at the actuator in the car and saw it rotate from position to position with zero problems. Remember, there is actual temperature change; it's just not hot enough - the cabin is barely warm. So I ruled the actuator problem out.

There have been episodes where, after sitting in slow traffic, the temperature in the cabin spikes up to suffocating levels! Leading me to believe, maybe there's a blockage somewhere. But when I check the reservoir there is no murky dexcool - Oh! Yes, I did perform a radiator flush, replaced the water pump, and the thermostat. YET the hose connecting to the driver side cabin is never piping hot.

So I am back to the radiator fans but this time checking the relays. I mean, why is this thing on as soon as the car is turned on? I start swapping fan relays 1, 2, 3 no change. Basically 1 & 2 are exactly that fan 1 & fan 2. Relay 3 is turbo fan speed. All seems to be on point with the relays, except when they remain un-plugged. When relays 1 & 3 are unplugged, the fans go on turbo mode. But when relay 2 is unplugged the fans do not go on automatically with the car and actually allows the temperature, both operating & cabin temps to go up. And yes, the temperature remains steady in the middle with the fans alternating between off and turbo.

I know, by driving with relay 2 unplugged, Im tempting fate and asking for trouble, but that is the closest thing to a solution which allows the fans to remain off until needed, let the temperature go up to middle and keep the cabin toasty. Still, what could be the problem? A bad thermostat stuck open or bad relays keeping the fans on?


.
ChevMali99 is offline   Reply With Quote
Old 11-19-2019, 07:05 AM   #2
Blue Bowtie
Registered Offender
 
Blue Bowtie's Avatar
 
Join Date: Mar 2006
Location: Rural
Posts: 6,086
Thanks: 4
Thanked 267 Times in 263 Posts
Re: Chevy Traverse 2009 - Testing why the low heat?

In an era where vehicles shut themselves off at stoplights to save six grams of fuel a day and LEDs are used to lighten the load on the alternator, it seems silly that having the radiator fans operate as soon as the ignition is turned on is correct. I would guess that indicate a problem in the PCM or its wiring. In fact, it used to be that if the fans turned on immediately, it indicated a fault mode of the PCM.

It could be beneficial to connect a scanner and monitor PCM inputs. This could reveal what the PCM thinks it is seeing, such as a coolant temperature in an incorrect range, or an AC pressure switch stuck closed, or a high transmission temperature.

But that may be a secondary problem. To maintain perspective, lots of vehicles with mechanical fans have been able to make and maintain coolant temperature with the fan moving constantly while relying solely upon the thermostat remaining fully closed until the coolant temperature reaches the proper level - Millions upon millions of vehicles, and for many decades.
__________________
Permanent seat assignment on the Group W bench...
Automotive Forums Survival Guide
Blue Bowtie is offline   Reply With Quote
The Following User Says Thank You to Blue Bowtie For This Useful Post:
ChevMali99 (11-19-2019)
Old 11-19-2019, 10:05 AM   #3
ChevMali99
AF Regular
Thread starter
 
Join Date: Oct 2008
Location: NYC, New York
Posts: 124
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Chevy Traverse 2009 - Testing why the low heat?

Thanks Blue Bowtie - I found this vid addressing AC pressure. I will follow up on that.

https://www.youtube.com/watch?v=9Z6uD_D2ErA
ChevMali99 is offline   Reply With Quote
Old 11-19-2019, 01:37 PM   #4
ChevMali99
AF Regular
Thread starter
 
Join Date: Oct 2008
Location: NYC, New York
Posts: 124
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Chevy Traverse 2009 - Testing why the low heat?

Found the AC pressure switch, disconnected it to see if the fan would not start but it did. Not sure if that's a good measure for testing and replacing but it is what it is. Maybe down the road I'll replace it, the part is cheap enough.
ChevMali99 is offline   Reply With Quote
Old 11-23-2019, 04:03 PM   #5
ChevMali99
AF Regular
Thread starter
 
Join Date: Oct 2008
Location: NYC, New York
Posts: 124
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Chevy Traverse 2009 - Testing why the low heat?

Followed the video's instructions:

Got out the OBDII reader and measured the kpa/psi given off by the ac high pressure switch while the AC was off, it was 420/60.

From there I turned on the AC and it constantly oscillated from 712/102 to 420/60. Not sure what is the normal for this car but I'll proceed to replace the ac high pressure switch since it's the easier cheaper option.

Also because the main concern continues to be the fan which is constantly on upon starting the car, thus preventing proper operating temperature & heat to the cabin; I doubt it's a bad (stuck open) thermostat but that would be my next item to look at.

What you all say?
ChevMali99 is offline   Reply With Quote
Old 11-25-2019, 11:31 AM   #6
ChevMali99
AF Regular
Thread starter
 
Join Date: Oct 2008
Location: NYC, New York
Posts: 124
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Chevy Traverse 2009 - Testing why the low heat?

SOLVED - yeap, replaced the ac high pressure switch, fans do not come on with the car, cabin and engine temperature warm up.
ChevMali99 is offline   Reply With Quote
Old 11-30-2019, 02:07 PM   #7
ChevMali99
AF Regular
Thread starter
 
Join Date: Oct 2008
Location: NYC, New York
Posts: 124
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Chevy Traverse 2009 - Testing why the low heat?

Oops - the condition has returned, maybe it never left. I've replaced the temp sensor, the AC high pressure switch, and thermostat. However, I've seen notes about the p0128 which is a code that alludes to a faulty thermostat but the presence of code itself makes the radiator fans come on. I will proceed to clear it and see if A) the fans shut off and B) if the code returns.
ChevMali99 is offline   Reply With Quote
Old 12-01-2019, 10:04 AM   #8
Blue Bowtie
Registered Offender
 
Blue Bowtie's Avatar
 
Join Date: Mar 2006
Location: Rural
Posts: 6,086
Thanks: 4
Thanked 267 Times in 263 Posts
Re: Chevy Traverse 2009 - Testing why the low heat?

Overcooling could be a sticky thermostat. If you want to "fool" the PCM, try connecting a 150Ω resistor to ground from the CTS and see if the fans shut off.
__________________
Permanent seat assignment on the Group W bench...
Automotive Forums Survival Guide
Blue Bowtie is offline   Reply With Quote
Old 12-01-2019, 09:42 PM   #9
ChevMali99
AF Regular
Thread starter
 
Join Date: Oct 2008
Location: NYC, New York
Posts: 124
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Chevy Traverse 2009 - Testing why the low heat?

What is the CTS?
ChevMali99 is offline   Reply With Quote
Old 12-02-2019, 06:48 AM   #10
Blue Bowtie
Registered Offender
 
Blue Bowtie's Avatar
 
Join Date: Mar 2006
Location: Rural
Posts: 6,086
Thanks: 4
Thanked 267 Times in 263 Posts
Re: Chevy Traverse 2009 - Testing why the low heat?

Coolant Temperature Sensor, sometimes also called ECT.
__________________
Permanent seat assignment on the Group W bench...
Automotive Forums Survival Guide
Blue Bowtie is offline   Reply With Quote
Old 12-31-2019, 03:47 PM   #11
ChevMali99
AF Regular
Thread starter
 
Join Date: Oct 2008
Location: NYC, New York
Posts: 124
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Chevy Traverse 2009 - Testing why the low heat?

FINALLY SOLVED (well at least the low heat part)!

The heater core was severely clogged and changed the thermostat for good measure. The fan still comes on with the car but does not stay on like before. The temperature stays in the middle and the fan comes on when the A/C (defog) position is selected as it should.
ChevMali99 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Chevrolet > Traverse

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:10 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts