Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Camaro | Firebird > F-Body Problem Diagnosis
F-Body Problem Diagnosis Got a problem you can't fix? Post here and one of our members will answer as soon as possible.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 05-12-2018, 07:48 PM   #1
stholt5233
AF Newbie
 
Join Date: Apr 2018
Location: Fayetteville, North Carolina
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
1989 Camaro IROC 5.7 only runs on starting fluid...

Ok, so the car only runs if I fog it. When I stop spraying the car stops too. I replaced the fuel pump and hanger, fuel pressure at the rail peaks at 50 then drops to around 42. According to a noid check, the injectors are firing. The car will run if I spray starting fluid into it, so I know I have spark. I had the ignition module checked at Autozone and it passed, but it is old. All the fuses are good. What's next?

The car did sit for a few years. The gas I took out wasn't too cloudy, but it was very amber. I cleaned the tank and put a few gallons of 93 oct gas to try starting it, but so far it will not catch. Doesn't even sound like it's trying. The plugs smell like gas, but don't seem wet.
stholt5233 is offline   Reply With Quote
Old 05-12-2018, 08:41 PM   #2
777stickman
AF Enthusiast
 
Join Date: Jan 2004
Location: Maybe
Posts: 1,831
Thanks: 6
Thanked 86 Times in 85 Posts
Re: 1989 Csmaro Iroc 5.7 only runs on starting fluid...

I suspect the injectors are not squirting fuel due to being plugged with old dried out fuel. There is a test for checking the spray pattern while cranking, just can't remember the details??

Good luck to you.
__________________
57 Chevy 210
65 Olds 442 Convertible (Another one sold)
75 GMC Vandura 3/4 Ton
05 Dodge Ram 3500/5.9 Cummins
2012 Toyota FJ Cruiser
1999 K2500 Old Body Style Suburban (Gone but not forgotten)
777stickman is offline   Reply With Quote
Old 05-12-2018, 09:07 PM   #3
Tech II
AF Fanatic
 
Join Date: Jul 2011
Location: Worcester, Massachusetts
Posts: 4,938
Thanks: 52
Thanked 609 Times in 601 Posts
Re: 1989 Csmaro Iroc 5.7 only runs on starting fluid...

I agree with stick....if it fires while spraying carb cleaner into the intake and dies when you stop, and you have fuel pressure and each injector passes the noid test, then there isn't enough fuel coming out of the injectors.......

Stick I believe this has 8 injectors, and is not TBI......the old trick for checking a spray pattern from a TBI injector was to set up a timing light and aim it at the fuel coming out of the injector.....if the light showed Puddling, instead of a conical spray, it was either the injector or the ECM....

Did this all happen at once or was this something that was getting progressively worse?-
Tech II is offline   Reply With Quote
Old 05-13-2018, 07:26 AM   #4
stholt5233
AF Newbie
Thread starter
 
Join Date: Apr 2018
Location: Fayetteville, North Carolina
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1989 Csmaro Iroc 5.7 only runs on starting fluid...

The car was left to my wife in a will, and had been sitting in a garage for 3 years without being started. I am thinking of trying to flush some cleaner through the fuel rail through the schrader valve and letting it sit for a while then blowing it out.
stholt5233 is offline   Reply With Quote
Old 05-13-2018, 07:51 AM   #5
Blue Bowtie
Registered Offender
 
Blue Bowtie's Avatar
 
Join Date: Mar 2006
Location: Rural
Posts: 5,895
Thanks: 3
Thanked 230 Times in 226 Posts
Re: 1989 Csmaro Iroc 5.7 only runs on starting fluid...

When the pump runs it flushes out the rails. You noted the initial surge of pressure to 50 PSI, and then noted the regulator opening , dropping the pressure to 42. That second fuel line returns to the tank from the regulator, and is flushing the fuel rails due to the regulator being on the opposite side from the fuel inlet. That should flush the rails and crossover pipes after a minute or so of pump operation.

The concern is that the fuel being pumped cannot get through the injectors. There are very fine inlet screens in each injector. There are also metal pintles in each injector which may be frozen in position from years of being static.

You can remove the injectors and send them out for cleaning and testing, or you can try to test them yourself. You could also replace the injectors and avoid future problems. If it is the 1989, that was the first year for Multec injectors in TPIs, and they were problematic.
__________________
Permanent seat assignment on the Group W bench...
Automotive Forums Survival Guide
Blue Bowtie is offline   Reply With Quote
Old 05-13-2018, 07:58 AM   #6
Blue Bowtie
Registered Offender
 
Blue Bowtie's Avatar
 
Join Date: Mar 2006
Location: Rural
Posts: 5,895
Thanks: 3
Thanked 230 Times in 226 Posts
Re: 1989 Csmaro Iroc 5.7 only runs on starting fluid...

Incidentally, the only places I would trust for injector cleaning and flow-matching are Cruzin' Performance in Michigan or Southbay Injection in NY.
__________________
Permanent seat assignment on the Group W bench...
Automotive Forums Survival Guide
Blue Bowtie is offline   Reply With Quote
Old 05-13-2018, 08:10 AM   #7
stholt5233
AF Newbie
Thread starter
 
Join Date: Apr 2018
Location: Fayetteville, North Carolina
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1989 Csmaro Iroc 5.7 only runs on starting fluid...

Hmm...I was trying to avoid taking them out...but, to me, if I am going through the time to take them out, I will probably just replace them, like you said, to avoid future problems. Any brands I should avoid?
stholt5233 is offline   Reply With Quote
Old 05-13-2018, 03:26 PM   #8
Blue Bowtie
Registered Offender
 
Blue Bowtie's Avatar
 
Join Date: Mar 2006
Location: Rural
Posts: 5,895
Thanks: 3
Thanked 230 Times in 226 Posts
Re: 1989 Csmaro Iroc 5.7 only runs on starting fluid...

DO NOT use the OEM Multecs. Bosch D3s are O.K.
__________________
Permanent seat assignment on the Group W bench...
Automotive Forums Survival Guide
Blue Bowtie is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Chevrolet > Camaro | Firebird > F-Body Problem Diagnosis

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:56 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts