Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > TrailBlazer | Trailblazer EXT
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 07-04-2013, 03:02 PM   #1
amflash
AF Newbie
 
Join Date: Jul 2013
Location: Hastings, Nebraska
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
problems with throttle body or components associated

DTC P1515, P1516, P1512, P1523
2003 Chevy trailblazer, The ses light is on, rep light came on, we removed throttle body to clened it (extremely dirty) and put it back on and it runs worse. When running live data with the diag tool, it has a very slow top speed, cleared codes while performing live scan and it ran perfect for about ten seconds. Then all the lights came back o and ran bad again. We inspected the wiring out of the throttle body into the map sensor and cleaned it with elec spray and nothing changed. Any ideas what the problem could be?
amflash is offline   Reply With Quote
Old 07-04-2013, 06:58 PM   #2
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,565
Thanks: 13
Thanked 323 Times in 317 Posts
Re: problems with throttle body or components associated

Check this U Tube video http://www.youtube.com/watch?v=U2DjMcM_Quk 1523 is the cam position actuator, take the plug off see if it is full of oil.
__________________
maxwedge is online now   Reply With Quote
Old 07-04-2013, 07:51 PM   #3
Tech II
AF Fanatic
 
Join Date: Jul 2011
Location: Worcester, Massachusetts
Posts: 5,017
Thanks: 70
Thanked 617 Times in 609 Posts
Re: problems with throttle body or components associated

There is no throttle cable...throttle plate is run by a motor assembly that get's it's input from the pedal position sensor and PCM.....there are tps sensors on the throttle plate, and when the sensors don't agree with each other or if they don't agree with the desired position, the VCM sets a code and causes reduced power....

Possibilities are bad wire, bad connection in wire harness(female connector has too much play), bad TPS sensors, bad motor in throttle body, bad pedal position sensor, PCM(very rare), etc.


Last edited by Tech II; 07-04-2013 at 08:45 PM.
Tech II is offline   Reply With Quote
Old 07-04-2013, 10:49 PM   #4
amflash
AF Newbie
Thread starter
 
Join Date: Jul 2013
Location: Hastings, Nebraska
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: problems with throttle body or components associated

First starting sensing there was a problem with the vehicle when I would start it would make a high pitched squealing or grinding sound which was the throttle sticking closed. After we cleaned it though, and it ran even worse, could it be anything other than wiring?
amflash is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
body, problems, throttle
Go Back   Automotive Forums .com Car Chat > Chevrolet > TrailBlazer | Trailblazer EXT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:28 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts