Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Engineering/Technical
Engineering/Technical Ask technical questions about cars. Do you know how a car engine works?
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-24-2001, 11:20 AM   #1
AbsurdParadox
AF Newbie
 
Join Date: Oct 2001
Location: dfasdf
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to AbsurdParadox
Intermittent stalling and other probs on 89 Firebird

(Also posting this in the Firebird Forums, trying to get as much info as possible)

Ever since I got my 89 Firebird about a year ago, it will just ... die... now and then, and I have no clue why. I've replaced the fuel filter, air filter, O2 sensor, cap/rotor/plugs, ran all kinds of different injector cleaner in it, checked computer codes (gives an "everythings okay" reading), uh... what else... heh, I've done quite a bit to it short of taking it in and having the actual injectors looked at. Also, if its sittin in park or neutral (yep, automatic, with the weak 2.8l 6 cyl) and I tap the gas, to get it revvin' at about 2500 rpm or so, and let off the gas, it will climb back down VERY slowly, barely moving/slowing down, until I hit the brake, and this is in park! Some sort of vaccuum leak or something, I dunno, you guys have ANY ideas?
__________________
-AbsurdParadox
92 VR-4
AbsurdParadox is offline   Reply With Quote
Old 10-30-2001, 09:29 AM   #2
enginerd
AF Enthusiast
 
enginerd's Avatar
 
Join Date: Sep 2001
Posts: 458
Thanks: 0
Thanked 0 Times in 0 Posts
I think you've nailed it. Check all your rubber tubing under the hood. Also spray some WD-40 or B-12 on the seam where the intake meets the cylinder head. If the engine speeds up, you've an intake leak. If you find a hose with a hole or crack in it, and put your finger over the hole and if the engine speeds up, replace said hose. If all else fails, you might have a vaccum leak INSIDE the engine (I've had those bite me as well) from the intake manifold. While your at it, check you linkages from the gas pedal to the fuel injection (sounds like the linkage/cable is binding). Oil the linkage (if you have one) or replace the cable.
enginerd is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
Cylinder misfire and other probs jpruessner C/K 0 09-30-2007 11:00 PM
Please Help 2000 LX 3.8 intermittant stall and jerk??? jaydadder Windstar 23 11-02-2005 07:26 PM
91 V6 Cav stalling and sputtering probs kylekyle Cavalier Problem Diagnosis 1 10-26-2005 12:41 PM
88 caravan stall and start probs when warm dammpa Caravan | Voyager 9 01-31-2004 08:26 AM
check engine light and other probs teaminvasion Integra 5 09-14-2003 11:15 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Engineering/Technical

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:37 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts