Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Toronado
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 09-07-2008, 11:19 AM   #1
battlecat
AF Newbie
 
Join Date: Sep 2008
Location: Oxford, North Carolina
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
1982 Toro,speedometer went out, can't figure out what's wrong...please help!

as the title says, I have a 1982 Toronado, gas engine, small block V8, cruise control. The cruise control has been acting strange...(the car would maintain speed but would slow down slightly, then surge back to selected speed... it would do this constantly, which was very annoying!). The other day, I noticed the speedometer needle "jumping" slightly. The next day, the speedometer quit altogether. A few seconds later, the "check engine" light came on (and stayed on). I figured the speedometer cable broke (because it acted just like a cable break); however, I dove into the job today to try to see what went wrong. Well, this thing has one cable that comes from the transmission that goes to the cruise control transducer. I removed that cable and checked it out (it was fine...no problem at all) I then removed the speedometer gear cover on the transmission and examined both gears very carefully...no problems there. I removed one end of the other cable that goes from the cruise control transducer to the speedometer head itself. I could easily turn it by hand (and watch the needle on the speedo move accordingly...no problems there). SO what could my problem be...that last link in the chain is the transducer itself....could THAT be the problem? and would this problem cause the "check engine" light to come on? IF I need a new transducer, where could I find one? Any suggestions are welcome!
battlecat is offline   Reply With Quote
Old 09-07-2008, 03:48 PM   #2
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,592
Thanks: 14
Thanked 327 Times in 321 Posts
Re: 1982 Toro,speedometer went out, can't figure out what's wrong...please help!

Welcome to AF, first what is the code, no info there, second see if the cable going into the transducer from the trans turns freely and does the output side turn the speedo cable.
__________________
maxwedge is offline   Reply With Quote
Old 09-07-2008, 06:20 PM   #3
battlecat
AF Newbie
Thread starter
 
Join Date: Sep 2008
Location: Oxford, North Carolina
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1982 Toro,speedometer went out, can't figure out what's wrong...please help!

Excellent suggestions, Maxwedge! Thanks for the response! I'll check out the code and will examine the output side of the transducer! Just one question: How do I check to make sure the cable going from the transmission to the transducer turns freely (other than to check that the cable was intact, in good shape, well-lubed, no kinks/bends - I removed the cable, then removed the inner cable from the casing, and examined it carefully, lubed it and replaced it....no problems there) ?
battlecat is offline   Reply With Quote
Old 09-07-2008, 08:49 PM   #4
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,592
Thanks: 14
Thanked 327 Times in 321 Posts
Re: 1982 Toro,speedometer went out, can't figure out what's wrong...please help!

Remove the cable from the trans and turn it manually see if the transducer turns freely. It will have some resistance, more than the head itself would. You are now checking if there is binding in the transducer, most likely this is the problem.
__________________
maxwedge is offline   Reply With Quote
Old 09-07-2008, 10:22 PM   #5
battlecat
AF Newbie
Thread starter
 
Join Date: Sep 2008
Location: Oxford, North Carolina
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1982 Toro,speedometer went out, can't figure out what's wrong...please help!

Quote:
Originally Posted by maxwedge
Remove the cable from the trans and turn it manually see if the transducer turns freely. It will have some resistance, more than the head itself would. You are now checking if there is binding in the transducer, most likely this is the problem.
Oh, okay, I gotcha now. I'll give that a try...thanks again, Maxwedge!
battlecat is offline   Reply With Quote
Old 09-20-2008, 08:44 PM   #6
battlecat
AF Newbie
Thread starter
 
Join Date: Sep 2008
Location: Oxford, North Carolina
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1982 Toro,speedometer went out, can't figure out what's wrong...please help!

okay, performed the test...definite binding in the transducer. Found a rebuilt transducer at Autozone ($83.00) and that fixed both the speedo and the cruise control (and I haven't read the code yet...but there's no "check engine light now, either!)
battlecat is offline   Reply With Quote
Old 09-21-2008, 09:22 AM   #7
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,592
Thanks: 14
Thanked 327 Times in 321 Posts
Thumbs up Re: 1982 Toro,speedometer went out, can't figure out what's wrong...please help!

Great, you really stayed with this, we are gratified when a sucessful ending is a result of these threads. You can see the logical progression required to narrow this down.
__________________
maxwedge is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Toronado

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:07 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts