Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mercury > Mystique
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 01-02-2005, 06:06 PM   #16
taximan
AF Newbie
 
Join Date: Jan 2005
Location: scarsdale, New York
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Re: Egr ...........check Engine Light?????

Quote:
Originally Posted by clydes270
All those codes sounds like what I just went through. I replaced no parts. Just removed the Intank Manifold and soaked it in cleaner for 2 days. It was really clogged. Then, I washed it out with a hose, dried it for a few hours in the sun. Now, no codes. Now, I make sure that I hit the redline once in a while each month.

ok, this cat below threshold thing is very common. We run a fleet of crown vic's and we have at least 3 cars with a engine light because of that. that is why i joined this forum.

there is a problem with the ford computers. i think this was even acknowledged by ford now. the computer just doesnt handle the O2 sensor info right when they have been on the car for a while. And no they aren't just bad O2s. Also if you replace one sensor you will get this code sometimes because the banks wont be even enough or something like that.

either way i know there is a fix for this problem. you can get the comp reflashed to accept a wider range. I dont know where to get it but i know its out there. and given how much these parts cost im sure it will save me cash to find it.

help?
taximan is offline   Reply With Quote
Old 01-08-2005, 08:07 PM   #17
galaxygrl2005
AF Newbie
 
Join Date: Jan 2005
Location: Redmond, Washington
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
95 mystique obd-II

I have a 95 mercury mystique and the check engine light has been intermittenly going on and off. Employees from both Autozone and Jiffy Lube were unable to find a place to plug in an OBD-II reader to diagnose the problem. I'm pretty sure it is not in the same place as the 96-2000 models. Does anyone know if 95 mercury mystiques have a place to plug in an OBD-II reader? If not, what is the best way to diagnose the issue? Thanks!
galaxygrl2005 is offline   Reply With Quote
Old 01-08-2005, 08:25 PM   #18
Marathonman
AF Newbie
 
Join Date: Nov 2004
Location: West Middlesex, Pennsylvania
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Re: Re: Egr ...........check Engine Light?????

Quote:
Originally Posted by taximan
ok, this cat below threshold thing is very common. We run a fleet of crown vic's and we have at least 3 cars with a engine light because of that. that is why i joined this forum.

there is a problem with the ford computers. i think this was even acknowledged by ford now. the computer just doesnt handle the O2 sensor info right when they have been on the car for a while. And no they aren't just bad O2s. Also if you replace one sensor you will get this code sometimes because the banks wont be even enough or something like that.

either way i know there is a fix for this problem. you can get the comp reflashed to accept a wider range. I dont know where to get it but i know its out there. and given how much these parts cost im sure it will save me cash to find it.

help?
Do you have anymore information on this Problem or know where I can find more? I think I'm haveing this problem with my Sable.
Marathonman is offline   Reply With Quote
Old 01-21-2005, 12:03 PM   #19
whirly1996
AF Newbie
 
Join Date: Jan 2005
Location: Mesa, Arizona
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Egr ...........check Engine Light?????

I own a 2000 mystique just came back from a trip to Minnesota on the way home check engine light came on I figured no big deal this has happened to me before due to the gas cap not being put back on right. about 900 miles into my trip the car starts chugging on any incline i.e on ramps ect. got home by the grace of Luck had a mechanic look at it and he said I need a new catyalitic converter he checked into prices and said this would run me almost 1,000 bucks. called Mercury to see what they would charge for a new converter and I almost fell over they quoted me $1,800.. well in the mean time my timing belt now went out cost me $350 bucks to get that replaced. needed the car to get to work so we just took off the converter till I can get the cash to replace it. and low and behold the check engine light is still on darn pesky thing lol
whirly1996 is offline   Reply With Quote
Old 03-23-2005, 07:08 PM   #20
Fgreco
AF Newbie
 
Join Date: Feb 2005
Location: brick, New Jersey
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Egr ...........check Engine Light?????

I have the same problem with the check engine light. Ive been to two guys the first gave me codes and said it was thousands of dollars. I didnt beleave them and whent back to my trusty mechanic and he pulled up only one code that said it was the catylitic converter. They reset the light it took about a month and it came on agian Iam going tomarrow to see what it is.
Fgreco is offline   Reply With Quote
Old 06-21-2005, 06:24 PM   #21
quilcene
AF Newbie
 
Join Date: Jun 2005
Location: Las Vegas, Nevada
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Re: EGR Valve

AuroZOne Told me the O2 sensor was bad/ How do I find those under the hood specifically please.??
I kinda know what it looks like but there are a few things under there appearing to to be the O2 Sensor.
Gratias--
quilcene is offline   Reply With Quote
Old 06-22-2005, 12:25 AM   #22
beyondloadedSE
AF Ford Contour-Advisor
 
beyondloadedSE's Avatar
 
Join Date: Mar 2003
Posts: 1,815
Thanks: 0
Thanked 2 Times in 2 Posts
Re: Re: EGR Valve

Quote:
Originally Posted by quilcene
AuroZOne Told me the O2 sensor was bad/ How do I find those under the hood specifically please.??
I kinda know what it looks like but there are a few things under there appearing to to be the O2 Sensor.
Gratias--
If it screws into the exhaust manifold, its an 02 sensor.
__________________

"The CEG Nazi"
www.contour.org
1996 Ford Contour SE - Sold
3.0L V6 and Arizona Dyno Chip Turbo Kit
364 whp, 410 wtq @ 16 psi and only 4,700 rpms.
1999 Tropic Green SVT Contour - Bone stock and MINT
beyondloadedSE is offline   Reply With Quote
Old 06-22-2005, 06:31 PM   #23
quilcene
AF Newbie
 
Join Date: Jun 2005
Location: Las Vegas, Nevada
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Re: Egr ...........check Engine Light?????

Quote:
Originally Posted by clydes270
All those codes sounds like what I just went through. I replaced no parts. Just removed the Intank Manifold and soaked it in cleaner for 2 days. It was really clogged. Then, I washed it out with a hose, dried it for a few hours in the sun. Now, no codes. Now, I make sure that I hit the redline once in a while each month.

Where is the O2 Sensor precisely--???
quilcene is offline   Reply With Quote
Old 06-22-2005, 11:37 PM   #24
beyondloadedSE
AF Ford Contour-Advisor
 
beyondloadedSE's Avatar
 
Join Date: Mar 2003
Posts: 1,815
Thanks: 0
Thanked 2 Times in 2 Posts
Re: Re: Re: Egr ...........check Engine Light?????

Quote:
Originally Posted by quilcene
Where is the O2 Sensor precisely--???
depends...what year and engine type?
__________________

"The CEG Nazi"
www.contour.org
1996 Ford Contour SE - Sold
3.0L V6 and Arizona Dyno Chip Turbo Kit
364 whp, 410 wtq @ 16 psi and only 4,700 rpms.
1999 Tropic Green SVT Contour - Bone stock and MINT
beyondloadedSE is offline   Reply With Quote
Old 06-23-2005, 12:52 AM   #25
quilcene
AF Newbie
 
Join Date: Jun 2005
Location: Las Vegas, Nevada
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Re: Re: Re: Egr ...........check Engine Light?????

Quote:
Originally Posted by beyondloadedSE
depends...what year and engine type?

2.5 L V6
98 Mystique

I sure could use a diagram to find it-
its nigh impossible to get out of the 1989 Ranger 4 cyl I have

But it looks like it may be on top in the Mystique
so one can get to it with a wrench easily.hopefully...

Thanks''
quilcene is offline   Reply With Quote
Old 06-23-2005, 12:53 AM   #26
quilcene
AF Newbie
 
Join Date: Jun 2005
Location: Las Vegas, Nevada
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Egr ...........check Engine Light?????

Oh Bye the way''
are there two that need to be removed or will one do. The sensor said something about Bank one and Bank two ___
quilcene is offline   Reply With Quote
Old 06-23-2005, 02:53 PM   #27
beyondloadedSE
AF Ford Contour-Advisor
 
beyondloadedSE's Avatar
 
Join Date: Mar 2003
Posts: 1,815
Thanks: 0
Thanked 2 Times in 2 Posts
Re: Re: Egr ...........check Engine Light?????

Quote:
Originally Posted by quilcene
Oh Bye the way''
are there two that need to be removed or will one do. The sensor said something about Bank one and Bank two ___
bank 1 and bank 2 refer to both sides of the engine. bank 1 being the rear of the engine and bank 2 being the front. It should have said upstream or downstream to refer to the 02 sensor and where its located on the manifold.
__________________

"The CEG Nazi"
www.contour.org
1996 Ford Contour SE - Sold
3.0L V6 and Arizona Dyno Chip Turbo Kit
364 whp, 410 wtq @ 16 psi and only 4,700 rpms.
1999 Tropic Green SVT Contour - Bone stock and MINT
beyondloadedSE is offline   Reply With Quote
Old 04-18-2007, 04:37 PM   #28
unclereggie
AF Newbie
 
Join Date: Apr 2007
Location: Hornell, New York
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Egr ...........check Engine Light?????

My daughter and her husband recently purchased a new car and gave me their 1998 Mercury Mystique LS Sport 2.5L V6.

When I attempted to inspect it in NYS, I was told that it would not pass inspection because the Check Engine light was on. I was further told that there was such a laundry list of possible causes to invesitigate that "it might not be worth it to me to proceed."

Say what? I should just junk the car because of a "Check Engine" light? No freaking way! Needless to say, I took the car home.

The inspection report stated that OBDII diagnostic codes P0171 and P0174 were present. I began to investigate these codes via the web and found several resources of valuable information, especially including this forum. Following a bit of sage advice I encountered here - try the simple first - here is what I did:

Incidentally, I am a total novice so bear with me...

I first located the Mass Air Flow (MAF) sensor between the air filter compartment and the ??intake manifold?? I discovered that I would need tamper proof star bits to remove the MAF. Off I went to the Advance Auto Parts store. For $22 I purchased the start bits, electrical contact point cleaning spray and a new air filter.

Opening the air filter compartment, I discovered what must have been the original 1998 air filter. It was so dirty that no air could possibly flow through it. Dirt literally fell off it in clumps and the compartment was full of sand and pine needles. I cleaned everything up and installed the new air filter.

Next I removed the MAF sensor. It did not look particularily dirty but one of the tiny wire coils did look a bit discolored. I thoroughly spray-cleaned the two wire coils using the contact point spay cleaner employing the furnished straw to direct and concentrate the spray on the wire coils. I then replaced the MAF sensor.

I do not own a diagnostic unit, so to erase the stored OBDII codes I disconnected the battery cable and went for lunch. After lunch, I reconnected the battery cable and started the car - no "Check Engine" light of course. I took the car out and up the highway for a 20-mile round trip and shut it off. I restarted it - no "Check Engine" light. Twenty minutes later I repeated the same trip, shut the car off and restarted it - no "Check Engine" light.

I drove the car again later today and still no "Check Engine" light. Tomorrow I will take the car to have the inspection completed at no further cost than the NYS fee. Had I owned the proper bits and the spray, my only added expense would have been the $7 air filter.

Needless to say, I will not visit the same inspection station again.
unclereggie is offline   Reply With Quote
Old 08-30-2014, 07:55 AM   #29
dave46052
AF Newbie
 
Join Date: Aug 2014
Location: Lebanon, Indiana
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Egr ...........check Engine Light?????

2000 Merc Mystique with the 2.5 V6. Check engine light has been on a long while. Had the EGR valve replaced recently, didn't help much. The engine surges at highway speeds, 60-70 mph. Around town it runs fine. If the carbon needs cleaned from the manifold, how much can I expect to pay? I've but hundreds of $$$ in this car and my patience is wearing thin. Thanks. (I know the cat converters are also throwing codes.)
dave46052 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Mercury > Mystique

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:20 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts