Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Bravada
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 06-30-2016, 02:20 AM   #1
Pasadeana
AF Newbie
 
Join Date: Jun 2016
Location: Hot Springs, Arkansas
Posts: 2
Thanks: 2
Thanked 1 Time in 1 Post
2002 Olds Bravada electrical problem

Went to install new stereo system and now nothing electrical inside the cab works. The Truck starts up no problem and drives. Just no power to windows, locks, interior lights, no stereo, no air/ac. The instrument panel/gauges work but the light doesn't. Checked Battery cables, fuses, and unhooked onStar (not used by us or previous owner). Can someone please help? Thank you.
Pasadeana is offline   Reply With Quote
Old 06-30-2016, 10:07 AM   #2
aleekat
AF Enthusiast
 
Join Date: Dec 2001
Location: clarksville, Tennessee
Posts: 1,412
Thanks: 6
Thanked 147 Times in 143 Posts
Re: 2002 Olds Bravada electrical problem

Had to be something during the stereo install. You'll have to back track and double check connections, pulled connectors, etc.
__________________
Post back, that's what makes Forums Work.
aleekat is offline   Reply With Quote
The Following User Says Thank You to aleekat For This Useful Post:
Pasadeana (06-30-2016)
Old 06-30-2016, 10:08 PM   #3
Chris Stewart
AF - Advisor
 
Chris Stewart's Avatar
 
Join Date: Mar 2004
Location: Nashville, Tennessee
Posts: 2,904
Thanks: 102
Thanked 41 Times in 39 Posts
Re: 2002 Olds Bravada electrical problem

I bought the install kit, with the special adapters when I put another radio in mine.
Chris Stewart is offline   Reply With Quote
The Following User Says Thank You to Chris Stewart For This Useful Post:
Pasadeana (06-30-2016)
Old 06-30-2016, 10:42 PM   #4
Pasadeana
AF Newbie
Thread starter
 
Join Date: Jun 2016
Location: Hot Springs, Arkansas
Posts: 2
Thanks: 2
Thanked 1 Time in 1 Post
Thumbs up Re: 2002 Olds Bravada electrical problem

We found the problem. I turned out to be the instrument panel battery in the fuse box under the hood. It tested fine with a voltage meter. Retested it with a test light and it was bad. Anyways, we found the problem. Thanks for your comments in helping me with my problem. Much appreciated.

Pasadeana
Pasadeana is offline   Reply With Quote
The Following User Says Thank You to Pasadeana For This Useful Post:
Chris Stewart (07-01-2016)
Old 07-01-2016, 11:42 PM   #5
Chris Stewart
AF - Advisor
 
Chris Stewart's Avatar
 
Join Date: Mar 2004
Location: Nashville, Tennessee
Posts: 2,904
Thanks: 102
Thanked 41 Times in 39 Posts
Re: 2002 Olds Bravada electrical problem

Thanks for the update.
Chris Stewart is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
2002, bravada, electrical, oldsmobile
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Bravada

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:22 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts