Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mercury > Mystique
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 02-13-2008, 04:05 PM   #1
Delineated
AF Newbie
 
Join Date: Feb 2008
Location: Mesa, Arizona
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mechanics. 95 Mystique

Hello everyone. I have recently purchased a 95 Mystique with 73,000mi on the 2.5 Duratec. Im having a few issues with it that i would like to fix. First problem is the hesitation. It hesitates when i first give it gas from a dead stop.. specially if I give it full throttle. but after a second or so it kicks in and goes. if I stomp it while going it doest do it really and it pulls ok.. I can tell all the power isnt there. It seems to be more in the low rpm range.. second it needs new shocks. there is some clunking going on in the rear that bothers me and some sound from the front. I was wondering if there were any good mechanics or someone knows of any in the east valley. Just would be better to work with someone that already knows these cars and there problems. Somewhere in Mesa, AZ or east Phoenix would be cool. let me know thanks.
Delineated is offline   Reply With Quote
Old 11-22-2010, 10:06 AM   #2
mojo12yo
AF Newbie
 
Join Date: Nov 2010
Location: North Port, Florida
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Mechanics. 95 Mystique

I had the same problem with my LS 95 and i recently got in a car accident. Not a bad accident but was able o fix the car by replacing the thermostat, radiator and the radiator hoses, after doing so I noticed a great increase in power and the stutter was gone in the car when i went to take off. Im thinking most likely its the thermostat to your radiator that might not be opening up properly causing a bog issue
mojo12yo is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Mercury > Mystique

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:33 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts