Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Nissan > 240Z | 260Z| 280Z | 300ZX (Past Z Cars)
240Z | 260Z| 280Z | 300ZX (Past Z Cars) The original Z cars - ones that started it all.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 05-21-2015, 12:18 PM   #1
Brandon505
AF Newbie
 
Join Date: Apr 2015
Location: Albuquerque, New Mexico
Posts: 59
Thanks: 0
Thanked 1 Time in 1 Post
96 300zx A/C unit indicator/display lights not working

In my 300zx the display on the A/C controller is frozen with only parts of numbers and the indicator lights on the buttons don't light, but all the fans and stuff work its just the lights and display. Anyone know exactly what could be wrong? i'm pulling up wiring diagrams to diagnose but figured maybe someone had this problem.
Brandon505 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Nissan > 240Z | 260Z| 280Z | 300ZX (Past Z Cars)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:09 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts