Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Honda > CL | Inspire | Saber | TL
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 01-25-2011, 03:19 PM   #1
giants200
AF Newbie
 
Join Date: Jan 2011
Location: San Francisco, California
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Acura CL 3.0 Check Engine Light P0401 error code

Hi, I have a 97 Acura CL 3.0 and my check engine light went on few months ago with error code P0401 (EGR Insufficient flow). Did some research online and people suggested if I clean the EGR ports/passage and replace the EGR valve the problem should be fixed. I did all those but the check engine light came back on again after 100 miles. Anyone can advise what I can do next? Do I need to replace other parts as well or need to check for air leakage? Thanks in advance.
giants200 is offline   Reply With Quote
Old 01-25-2011, 07:21 PM   #2
BullShifter
AF Moderator
 
BullShifter's Avatar
 
Join Date: Jul 2002
Location: Homeless, Illinois
Posts: 6,215
Thanks: 1
Thanked 14 Times in 13 Posts
Re: Acura CL 3.0 Check Engine Light P0401 error code

Did you remove the intake plenum to clean that port?
BullShifter is offline   Reply With Quote
Old 01-26-2011, 01:50 PM   #3
giants200
AF Newbie
Thread starter
 
Join Date: Jan 2011
Location: San Francisco, California
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Acura CL 3.0 Check Engine Light P0401 error code

Thanks for the reply BullShifter. Yes, I have cleaned the intake plenum, and the light still came back on after 100 miles.
giants200 is offline   Reply With Quote
Old 01-26-2011, 05:29 PM   #4
BullShifter
AF Moderator
 
BullShifter's Avatar
 
Join Date: Jul 2002
Location: Homeless, Illinois
Posts: 6,215
Thanks: 1
Thanked 14 Times in 13 Posts
Re: Acura CL 3.0 Check Engine Light P0401 error code

Hmmm, you did the whole update with cleaning/drilling the port, installing the sleeve and a new egr valve? I've never had one come back after doing the update until many thousand miles later when the port clogged again.
BullShifter is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Honda > CL | Inspire | Saber | TL

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:41 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts